WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 2.5 and TinyMCE not working in visual mode

[Resolved] 2.5 and TinyMCE not working in visual mode

  • First, I’ve got to say the responses that have been posted when people have tried to report this have been poor. The responses have just been a simple repetition of the same “solutions” which have been nothing of the sort.

    Second, there’s clearly a whole class of problems here and I’m focussed on the one I have for obvious reasons.

    So, how to verify you’ve the same problem. Use some sort of debugger tool like firebug etc, Peter Hengl gives a nice description here : http://wordpress.org/support/topic/164990

    The first thing to establish is that it’s not a cache problem, at least not in the way that keeps getting posted. For a start, browser and network caches don’t work like that. What I did find was that different files were returned using different clients, any browser (opera, safari, firefox) over three OS’es (Mac OSX, XP, Linux) returned a “cached” file that didn’t reflect debugging changes I made on the server, it was instantly obvious from a network trace that this wasn’t held in any browser cache. However, curl and wget instantly reflected the debug code, someone should have tried that before blaming caching as it’s obvious when you look at the code in tiny_mce_config.php why that’s going to be different. In fact, looking at the code I’d guess this would also work correctly (this far) in IE5.

    To fix this, remove the files from wp-content/uploads/js_cache and you’ll start getting an up to date copy of the mce code. NOTE, not everyone will have this issue as such, the cache code is broken in a way I’ve not fully analysed so this is a nuisance rather than the root cause.

    Next, to the source of the real problem. The debugger instantly spots this, it’s related to some I18n code and follows back to the get_locale function. The function is weak and used weakly in places which is why there’s a problem. This problem will most likely effect people not using 100% English language environments like Peter who’s German or me with Swiss/French locale, in fact, Peter’s nationality already made me guess the I18n code was broken.

    The simple fix is to go to your wp-config file and set the WPLANG variable to something suitable. For me, “en” is fine.

Viewing 15 replies - 1 through 15 (of 38 total)
  • Thank you! I had been having the problem and did what you said regarding:

    “To fix this, remove the files from wp-content/uploads/js_cache and you’ll start getting an up to date copy of the mce code.”

    Best of luck to everyone else.

    don’t work!

    Woohoo .. worked for me .. my WPLANG was set to ” “, I changed it to “en” and now it’s working !!

    i have setted to english but dont work.
    now i have found italian solution for this problem on this web site:

    Problemi con Visual editor di WordPress 2.5

    This doesn’t work for me either.

    where do you set it to english? what does the code look like. I am not a programmer so I need the name of the file to edit and the line of code.

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    @donnye normally you don’t need to change this setting if your language is English. However if you have multi-language plugin(s) installed or an internationalization script, there’s some info:
    http://codex.wordpress.org/Editing_wp-config.php#Language_and_Language_Directory

    deleting the js_cache worked for me too.
    Thanks!

    I have tried to delete the js_cache and set the WPLANG to ‘en’ but none of the things worked for me.

    Anyone who know other solutions for this problem?

    have you see the solution on my blog?
    go to
    [path blog]/wp-includes/js/tinymce/

    Edit file tiny_mce_config.php
    ‘compress’ => true
    with
    compress’ => false.

    remove files on dire

    [path blog]/wp-content/uploads/js_cache/

    to rat86:
    doesn’t work

    My problem was a server 500 error that prevented several PHP files that generated tinyMCE JS from running. My hosting service requires PHP files to not have Group and Everyone “WRITE” permissions (755). When I uploaded the WordPress 2.5.1 files the entire wp_includes folder came across at full rights (777). Once I change the permissions (recursively) to 755 it all worked.

    don’t work!!

    I have tried every fix in all the forums I can find and nothing works. The visual editor is broken. I can’t add pictures. I can’t update existing files. Very frustrating. I use godaddy and I wonder if they did something.

    Did you find a solution? I’m also using Godaddy and 2.5.1 and nothing seems to be working. I tried // out the compression and that did something to the /wp-includes/js/tinymce/tiny_mce_config.php file (before it was displaying the TinyMCE logo and now it’s displaying the code in a bungled manner – it’s all there, I think, but not separated line by line and I can’t figure that out since in Wordpad it opens normally (but not Notepad).

    My URL is http://israeli-wine.org

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘[Resolved] 2.5 and TinyMCE not working in visual mode’ is closed to new replies.