Support » Fixing WordPress » 2.5 and Blank Widgets

  • Hi!
    I have a big problem in many of my blog.

    Text Widget: When i change the content, add a text widget or delete, the content of the other text widget is blanked.

    I have tested this on many blog, but i have the same problem…

    Anyone know this ?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Good that somebody else has “widget issues”. My problem with it is that when I add a text widget, it is the same as the text widget which is already in the sidebar and I can’t edit the new one. When I click “change”, it simply disappears. Moreover some widgets have such a wide window when I click “change” that I only see half of it and the “remove” button falls off. When I drag (but I can’t drop), the whole widget appears, but I still can’t work in it.

    Did you test the widget screen in different browsers? I haven’t yet, I only have IE at work and haven’t found the time to test much at home.

    Gangleri is the same problem 😉

    I have tested only with Firefox!

    Ok, I have test FF and IE7. I’ll have a look at Browzar when I come home, but experience learns that it usually behaves like IE.

    Could somebody else please confirm or deny the problems? I’d like to know if it’s my installation, something inside WP or something completely different.

    I confirm Gangleri’s problem in the original post about adding a text widget, and would really like to get this issue resolved quickly if possible. Thanks.

    any solution or is a bug in wp 2.5 ?

    If you upgraded, I suggest to disable the browser cache so caching is not an issue. Then I suggest to disable javascript as well, so that javascript is not an issue.

    If both things are disabled, then please try again. If your problems still exists, please post details about it again here.

    If it doesn’t exist any longer, then try to first enable javascript again. Check again. If everything works as intended, then as last step, enable the cache again.

    Thanks hakre. I did as you suggested, and also purged my cache. It worked and I was able to add a new text widget.

    However, the problem seems to be having javascript enabled because when I re-enabled javascript, the same problem occurred and I was not able to add another text widget. Does this mean that we need to remember to disable javascript every time we want to add these types of widgets, or is there a better, more permanent work-around?

    Thanks again for your help!

    I upgraded two of my five ‘live’ WP’s (and they’ve been the most troublesome to date). However the issues with the widget page in the admin panel doesn’t appear in FF (but it is still present in IE7), now the widgets themselves make problems. The search widget doesn’t appear in the sidebar and my Google search text widget does. When using the archive, they ‘swop’, the search widget appears (ugly) and Google is gone. Now at work the Google text widget is empty and of course disappeared and the search widget doesn’t work.
    I keep having troubles with widgets in 2.5. Anyone who has them too? (Or preferably “had”)?

    Hi connectedudde, well I think disabling javascript should be an option but not the only option to edit widgets. Since the admin interface is new and your problems are javascript related I assume that some changes will come there anyway. I encountered multiple Issues with the widgets admin from upgrading issues to those javscript related ones. And since widgets are often created by plugins, this might be a plugin issue as well. The output of the html/jasvascript isn’t even correct for the widgets page in 2.5.

    @gangleri: Please check this thread, you find a description on how to reset the widget settings. Some other widget upgrade related threads are linked there as well.

    The Widget problems I encountered and “had” so far were API related. That leads for me in re-writing a plugin to hopefully fix them now and forever. Maybe I can share some PHP5.2 code later on for other plugin authors if interested.

    Hi Hakre (and others). Just a short update. I have six (including a test site) WP installations to upgrade and I noticed that on the third of it, the widget page works just fine (in Firefox that is, not in IE7), so it can’t be nothing else than troublesome installation. Indeed I did have problems with upgrading all three sites that I did so far. I can’t just remove WP files (“access denied”) and upload new ones, so I tried to overwrite, but also that doesn’t exactly run smoothly. After finding out where mistakes lay, I just try to start re-uploading files that may cause the problem, so yesterday I uploaded all four files widgets.php and widgets.css and that simple action solved the problem. Now I can just change widgets, add, remove, etc. I did get another search widget (Proper Search), because the default search widget can’t have a title.
    In any case, the problems prove to be simple and due to upgrading problems. Just so you all know.

    Hi – I have much the same problem with my widgets panel – could you please tell me exactly which files you replaced?
    I’ve searched through it all and can’t find more than 3 “widget.php” files. Without any luck I’ve deleted and uploaded fresh files to
    – wp-admin/widgets.php
    – wp-includes/widgets.php
    – wp-admin/includes/widgets.php
    I’ve also replaced css files:
    – wp-admin/css/widgets-rtl.css
    – wp-admin/css/widgets.css
    and also
    – wp-admin/js/widgets.js
    By the way, when upgrading I deleted (did not just overwrite) old files, I’ve deleted FF’s cache etc.
    Missed something?
    Grateful for any hints

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘2.5 and Blank Widgets’ is closed to new replies.