Support » Fixing WordPress » 2.3.1 not showing visual editor

Viewing 15 replies - 31 through 45 (of 45 total)
  • I had the same problems. I maintain several sites that use WordPress.

    My provider offers CPanel X for site control. And with that is Fantistico, a way to add programs like WordPress automatically to a site.

    Some sites had PHP 4.x.x and Fantastico was not installed and the visual editor didn’t work with the upgraded WordPress.

    The other sites had PHP 5.x.x and Fantastico was installed and the visual editor worked.

    I contacted my provider by email and asked to have all the sites I’m responsible for updated to PHP 5.x.x and to have Fantastico installed. That did the trick.

    I have an log that resides in a subfolder of my company site. When I open the admin with the URL of my personal site, no visual editor is shown.

    When opening the admin through the path of my company site with the subfolder added it shows.

    The last one is the real server path, my personal url is redirected tot a subfolder of that domain.

    What worked for me was to delete all the files in /wp-includes and then upload a fresh set, instead of just simply uploading the files for 2.3.1. Guessing there were some files from previous WP versions borking things.

    I’ve read about 50 threads on this same problem, tried everything that has been suggested, and nothing works.

    I think it’s apparent that it’s a bug with WordPress, and something that Automattic should address. Can this thread be made sticky so that we can get everyone focusing on the problem, and not 50 threads about the same topic?

    I really need to get this fixed, I’m using wordpress as a CMS for my company’s intranet, and I’m getting bombarded with emails and phone calls about why the WYSIWYG isn’t working.

    Help!!!

    Fixed it!

    ——-

    So I had a similar problem, but it was definitely an issue with the server not supporting gzip properly. (Everything worked on my local server). I went in to this file:

    /wp-includes/js/tinymce/tiny_mce_gzip.php

    and found this code:

    if ((in_array(‘gzip’, $encodings) || in_array(‘x-gzip’, $encodings) || isset($_SERVER[‘—————‘])) && function_exists(‘ob_gzhandler’) && !ini_get(‘zlib.output_compression’) && ini_get(‘output_handler’) != ‘ob_gzhandler’) {
    $enc = in_array(‘x-gzip’, $encodings) ? “x-gzip” : “gzip”;
    $supportsGzip = true;
    }

    Immediately after I overrode the $supportsGzip var with a false value by inserting the following line after the block reference above:

    $supportsGzip = false;

    Bingo! everything works fine now.

    —–

    I fixed the error!

    I was having problems with this as well on my site http://www.lilaussieprems.com.au. I have been getting error messages that i have exceeded the database size etc. and ever since getting that message i lost the visual editor feature.

    To fix the problem i just uploaded a new fresh copy of the tiny_mce_gzip.php and it’s working perfectly. If it wasn’t for cyzum’s post i would not have known which file to look at, so THANK YOU!!

    I was having an issue in Firefox 2.0.0.11 where the TinyMCE images were not displaying in my posts or pages wysiwyg editor. I was getting frustrated because there seemed to be no solution. My gut told me the images were corrupted and not the JS code. So I went to wp-includes/js/tinymce/themes/advanced/ and deleted the images folder. I then re-uploaded the folder with my transfer preference as auto vs. ascii. I then changed the permissions on the folder to 755 and logged back into my admin screen.

    The images appeared just fine in the tinyMCE and now my wysiwyg editor function is working fine. Not sure if this will work for others, but it worked for me.

    For me, the problem was an auto added utf-8 header in my webserver’s config file (lighttpd).

    I’d just like to add my name to this list of people having this problem.

    It occurred for me after I moved the WP to a different directory. I have done this without any problems before – and in this case the only side-effect is the visual editor disappearing. Completely ruined my day and probably my weekend. Oh well!

    I tried the gzip solution and it appears to have worked. Might have enjoyed my weekend if I’d have tried that Friday!

    cyzum you rock.

    Hours of work could have been saved by reading your post sooner. It was just too far down the list. This should be stickied.

    I edited my tiny_mce_gzip.php and all is well now.

    STICKY THIS!

    StoraX

    (@storax)

    Hello ,

    i have this problem . Before , i have a host on Lunarpages . Now , i have a VPS and load my backup new VPS . But i have a problem about this . i have a screen shot :
    http://img186.imageshack.us/img186/7640/abcul3.jpg

    what is the problem ? this problem based on php rules ?

    StoraX

    (@storax)

    Opppsss … Any answer ?

    There is no file by that name in my structure, nor is it in the 2.6.3 distribution.

    ???

    iridiax

    (@iridiax)

    This is an old forum topic for WordPress 2.3.1. Try newer topics:

    http://wordpress.org/search/visual+editor?forums=1

Viewing 15 replies - 31 through 45 (of 45 total)
  • The topic ‘2.3.1 not showing visual editor’ is closed to new replies.