Support » Fixing WordPress » 2.3 upgrade –> wp database error

  • Resolved plastiquemonkey


    i can see from multiple posts on the forum that i’m not the first to have a newly-missing from 2.3 database table cause errors after upgrading. i’m only writing here because i’ve tried various solutions described here and the problem is still ongoing.

    my error message is:

    WordPress database error: [Table ‘****_****blog.wp_categories’ doesn’t exist]
    SELECT * FROM wp_categories

    i’ve deactivated all plugins and updated to a supposedly compatible version of the theme (tarski 1.7.1). the error message is still there.

    i’ve tried the extended upgrade, deleting files as specified here, then re-uploading the 2.3 files, but the error is still there.

    any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Where are you seeing the error? On your site? What happens if change to the WordPress Default 1.6 theme?

    tried that already, just forgot to mention. even when i change to the default theme, the error is still there.

    when i first click a link i get an all-white page with the error message top left. then, half a second later, the page loads with the error message right at the top, centered. it’s sitting just above the header image.

    interesting — on the “About” page the same error message shows up in the sidebar, just above the categories (which then display below it, normally).

    and then, under the about page i get this:

    Fatal error: Call to undefined function: update_comment_cache() in /home/../../../wp-includes/comment-template.php on line 303

    is it a theme issue?

    I’d consider deleting the WordPress files and reuploading as per Steps 7 and 8 in Upgrading_WordPress_Extended.

    i did that already. should i try it again?

    You got a link to see the problem?

    I have the same error on an upgrade I did today. I cannot post the URL because of the content of the blog.

    WordPress database error: [Table ‘xxxxxxxxxxx.wp_categories’ doesn’t exist]
    SELECT cat_name FROM wp_categories ORDER BY cat_name ASC

    so i rolled back the entire upgrade — dropped tables and imported my db backup, deleted all files and re-uploaded my backups — then went through the upgrade again, this time upgrading to tarski 1.7.1 (2.3 compatible) *before* upgrading wordpress…

    …and it worked, perfectly. no idea why the initial problem — maybe the error was being cached somehow?

    anyway, thanks for your help.

    Okay, found the issue, the “Add Meta Tags” plugin apparently wants a table that no longer exists.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘2.3 upgrade –> wp database error’ is closed to new replies.