2.3 Upgrade broke mod_rewrite/friendly URLs (12 posts)

  1. NewMediaistcom
    Posted 7 years ago #

    I'm on a shared hosting provider, and used the following .htaccess file for SEO / friendly URLs for the last 2 years - always worked perfectly:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !index.php
    RewriteRule (.*) /index.php/$1 [L]

    Ever since upgrading to 2.3, mod_rewrite stopped function properly. Although all the friendly URLs are outputted properly by WordPress, actually trying to visit any of them results in a "the server is redirecting the request for this address in a way that will never complete.".

    Anyone have any idea how to fix this? I guess the changes the dev team made to the Friendly URL writing section of wordpress has broken my .htaccess file :(

  2. Colin Helvensteijn
    Posted 7 years ago #

    Nah, your .htaccess it's not. It looks exactly the same as mine (at least the WP section of mine).

    I do have a similar problem on my local test installation, thouhg with me it's only the RSS URL. Safari also claims that there are too many redirects (which it should even be aware of because Apache and WP o that all internally).

    Anywhay, that only goes for the RSS feed URL, orther URL work perfectly fine.

    No sure how this would help you, other than the confirmation that there's nothing wrong with your .htaccess file...

  3. Dion Hulse
    Lead Developer
    Posted 7 years ago #

    Hm, I have a feeling this is due to the canonical redirection functionality, Its not the permalink code, just redirects incorrect permalinks to their correct ones i believe.

    Theres been a few reports of similar problems, I think your going to have to disable the functionality, or get a WP dev. to look into your servers configuration to determine whats going wrong with WP.

    I'd suggest posting in the Wp-testers mailing list, and see if someone who can debug it can help out.

    I'd offer to look at it, but i'm not entirely sure of how to debug that function.

    If you just want to disable that functionality for now, then edit /wp-includes/canonical.php and comment out the final line:
    add_action('template_redirect', 'redirect_canonical');
    change to:
    //add_action('template_redirect', 'redirect_canonical');

  4. NewMediaistcom
    Posted 7 years ago #

    Thanks for the reply raptorNL - that's unfortunate that its not my .htaccess file, as that means I now need to reach out to my hosting admin, and they're not exactly the most helpful bunch.

  5. roganty
    Posted 7 years ago #

    I have a similar problem, I have just upgraded wordpress to 2.3 and the next/previous links produce the same "the server is redirecting the request for this address in a way that will never complete." error!

    The web host that I use is lycos, and I have the Verbose Rewrite Rules by Ryan Boren plugin installed because the compact rewrite rules do not work for me.

    Before the upgrade the next/previous links were working, and then after the upgrade clicking the next link just loaded the same page.

    I have tried deleting the .htaccess file and recreating the rewrite rules, with and without the plugin activated, and I have tried different rewrite rules.
    The only one that has worked is the default, no rewrite rules!

  6. roganty
    Posted 7 years ago #

    I've just checked back after work and I've just seen the reply by dd32, strange how I never saw it before posting because I followed the instructions and it is now working!

    Thank you dd32!

  7. vocaro
    Posted 7 years ago #

    I found a way to fix this problem without disabling the canonical redirect feature. The fix is described here:


  8. roganty
    Posted 7 years ago #

    That fix wouldn't work for me, as my web host redirects domain.com to http://www.domain.com, and I have the www prefixed to both urls

  9. chaos0815
    Posted 7 years ago #

    as roganty I'm a Lycos 'sufferer' and therefor very gratefull for dd32's hint!

  10. alliesrr
    Posted 7 years ago #

    I'm having this problem and the conical change isn't helping and I can't access my admin to shut down the problem in the options.

    Any ideas?

  11. modernape
    Posted 7 years ago #

    Just a suggestion, as I had the same problem, downloaded my whole site as a backup, then installed update etc, then friendly the URLs were all broken.

    But when .htaccess is downloaded and saved locally, it becomes just 'htaccess', so when reuploaded to the server, make sure you rename it with the dot at the front, or it won't work.

  12. donnie98125
    Posted 7 years ago #

    I was having the same problem ONLY with ONE of my blogs (WP 2.5, installed in a separate dir, not the root dir on the server.)
    My category links showed up on the page, but I kept getting that 'cannot redirect' error.
    dd32's simple line change worked for me. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic