WordPress.org

Forums

Jetpack by WordPress.com
[resolved] 2.2.3 warning (17 posts)

  1. Fabrizio Pivari
    Member
    Posted 2 years ago #

    I've just upgrade the plugin (WordPress 3.6-beta1-24095).
    This is the
    Warning: Invalid argument supplied for foreach() in /home/culturet/public_html/wp-content/plugins/jetpack/jetpack.php on line 4534

    http://wordpress.org/extend/plugins/jetpack/

  2. Fabrizio Pivari
    Member
    Posted 2 years ago #

    I've the problem at
    http://www.culture-tourism.org/

  3. jason102178
    Member
    Posted 2 years ago #

    I too just upgraded too 2.2.3 today and i am getting the warning

    Warning: Invalid argument supplied for foreach() in /wp-content/plugins/jetpack/jetpack.php on line 4534

  4. probablynot
    Member
    Posted 2 years ago #

    @jason102178 I noticed that both Fabrizio and I have bbpress on our sites. Do you as well? This could be the problem as there is a bit of code right before that foreach() specific to bbpress.

  5. jason102178
    Member
    Posted 2 years ago #

    @probablynot Yup i do , i never use to have bbpress, afer 5 yrs i finally installed bbpress yesterday.

  6. Fabrizio Pivari
    Member
    Posted 2 years ago #

    I've bbpress 2.3.1 and WordPress 3.6-beta1-24095 (and buddypress)

  7. jason102178
    Member
    Posted 2 years ago #

    yeah I too have BBpress 2.3.1 and i have wordpress 3.5 i don't have the beta version

  8. jeepdon
    Member
    Posted 2 years ago #

    +1. bbPress 2.3.1 and same error with Jetpack 2.2.3. Rolling back now, in fact.

  9. Lazylonewolf
    Member
    Posted 2 years ago #

    This happened again on my website from the last update before this.

    I "fixed" it by deleting the code in public_html>wp_content>plugins>jetpack.php

    foreach ( $_jetpack_rest_api_compat_includes as $_jetpack_rest_api_compat_include )
    	require_once $_jetpack_rest_api_compat_include;

    I really hope the developers fix this.

  10. probablynot
    Member
    Posted 2 years ago #

    If you comment out the lines:

    if ( function_exists( 'bbpress' ) )
    	$_jetpack_rest_api_compat_includes = dirname( __FILE__ ) . '/class.jetpack-bbpress-json-api-compat.php';

    it also works.

  11. Denis Ciumbargi
    Member
    Posted 2 years ago #

    Same error, bbpress also, buddypress, my error shows an extra line with nivo slider.

  12. Lazylonewolf
    Member
    Posted 2 years ago #

    Should we request support from buddypress too?

  13. Fabrizio Pivari
    Member
    Posted 2 years ago #

    I came back to 2.2.2.
    Everything good!

  14. bradleyrose001
    Member
    Posted 2 years ago #

    How do you roll back to 2.2.2?

  15. bradleyrose001
    Member
    Posted 2 years ago #

    Deactivating the bbPress plug-in got my site to not have those error messages on top in the live version.

  16. Fabrizio Pivari
    Member
    Posted 2 years ago #

    I'm not a great wp expert.
    To roll back I go to
    http://wordpress.org/extend/plugins/jetpack/developers/
    download version 2.2.2
    and install it via ftp but I think you can install directly the zip

  17. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    We have now updated Jetpack to solve this issue. You can update to 2.2.5 to solve this problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.