Support » Plugin: WooCommerce » 2.2.2 updated now cart empty after adding products

  • Resolved Ladyfyre

    (@ladyfyre)


    One of my websites has just auto updated to WP 4.0 and Woocommerce 2.2.2 and now the cart always shows up as empty after adding products to it.

    Not sure if it is related but the (non techie owner) who only has Shp Manager permissions saw the *wp-admin/admin.php?page=wc-settings&do_update_woocommerce=true button and clicked on it then received the do not have permission message. I have tried to add the update date link manually but it just goes to the Welcome to Woo Commerce 2.2 screen.

    I am running WP and Woo on my own personal website with a lot of the same plugins and everything is running smoothly so stumped.

    https://wordpress.org/plugins/woocommerce/

Viewing 9 replies - 1 through 9 (of 9 total)
  • just bumping this up in the hope that anyone can please help?

    just bumping this up in the hope that anyone can please help?

    I have fixed it though by renaming the Woocommerce plugin folder woocommerce_bak and ftping an older version from a June backup in it’s place. Then I updated Woocommerce and it then allowed me to update the data, all working now and without the few days worth of data that would have happened if I had done my next course of action and replaced the installation with a back up! (just explaining incase any one else has this problem in the future)

    ok can you walk me through this a bit… tried this and i put 2.1.12 in place and it showed no orders?

    Hi Jpyarger, unfortunately after testing today it turns out that add to cart is only working in Opera, but not on Chrome, iE, or android. I am totally stumped.

    temporary fix here

    This fix with the disableing of the AJAX still has some problems… I found that I had to disable the “allow checkout as guest” option. If you try adding to the cart without being logged in on chrome you still get the problem.

    Also I do still have problems on mobile version, but it is when you try to eliminate items from the cart… it doesnt allow you to.

    I hope these bugs get solved. I think WPML is to blame in my case… as I already downgraded my woocommerce from 2.2.2 to 2.1.12 and it solved some “category-product page” problems I had but this cart problem didn’t go away.

    Plugin Author Claudio Sanches

    (@claudiosanches)

    Fixed in 2.2.3

    Installed 2.2.3
    It works on Chrome now, but not on Firefox or IE!

    suggestions?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘2.2.2 updated now cart empty after adding products’ is closed to new replies.