WordPress.org

Support

Support » Themes and Templates » [Resolved] 2.2.1 Broken Template

[Resolved] 2.2.1 Broken Template

  • Since upgrading to 2.2.1, my custom template and all associated themes are broken. I had 1 template with 5 themes that ran off it, and none work suddenly, despite working since 1.x. If I delete the “Template:…” line from the main templates stylesheet, it will work fine, but no such fix for the style only themes.

    Main template is at http://www.atomicow.org/wordpress/wp-content/themes/atomic/

Viewing 10 replies - 1 through 10 (of 10 total)
  • There are no “style only” themes.
    There were WP “styles” during v1.2 and earlier but since 1.5 they don’t work – unless you hack WP.

    I don’t remember doing any hacks, and they seemed to work fine so far though 2.x so far.
    I guess I must have hacked something and forgot.

    Thanks

    I think maybe I am stating my situation wrong. I have 7 themes, only one of which contains full template files. The other 6 contain only a style.css, indicating the 7th as the parent using “Template: atomic” in the description.

    Aha, I got it.

    I guess I am just confused because the codex lists several examples of how to set up themes to work this way, making it unclear how it could be a long depreciated feature.

    As I said, I am rather sure I didn’t have a hack set up to make it work, and yet it worked through sever al versions past 1.5.

    Maybe I just lucked out or something.

    So the fix would be to duplicate all the .php template files from the one theme and put them into the other 6 themes folders?

    It maybe worth a try…

    That fixed it.
    Thanks for your help.

    I am having the same problem. NOT ONE SINGLE THEME other than Classic and Default work on WP 2.2.1 for me. They work on other installs (e.g. 2.0.10). So I tend to think it’s not a theme/template problem, but a 2.2.1 problem.

    All the stylesheets contain the requisite information commented out at the top as to the folder name and theme name.

    All *.php and *.css files were uploaded in ascii mode.

    The same themes were uploaded to other installs NOT running this latest WP and they work just fine.

    Any thoughts? I’m at a loss.

    I don’t think this is resolved. I just did a fresh install of 2.1.1 and NONE of the templates work… even default and classic.

    Dumping and resetting now… going to 2.2

    For the original poster (OP) it has been resolved. Only the OP can set it to resolved.

    Start your own topic, people don’t look at “resolved” threads.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] 2.2.1 Broken Template’ is closed to new replies.
Skip to toolbar