2.2 Upgrade with errors on wp-upgrade.php and login.php (6 posts)

  1. arm0110
    Posted 9 years ago #

    I've completed the upgrade from 2.1.3 to 2.2. When I tried to run the upgrade script, the expected upgrade window never displays, but when I view my blog the new version is listed in the footer.

    Then when I try to bring up the login screen, I get the following error message:

    Fatal error: Call to undefined function: get_admin_page_title() in ...//wp-admin/admin-header.php on line 12

    My blog is running on MySQL 4.0, phpMyAdmin 2.7.0.

  2. arm0110
    Posted 9 years ago #

    Sorry, running on PHP 5.

  3. MichaelH
    Posted 9 years ago #

    Wonder why you didn't see the Database needs updating message when you logged it. The Version 2.2 at the bottom of the screen is a result of the file wp-includes/version.php so if you uploaded the 2.2 files that is what you should see displayed.

    Did you delete the appropriate WordPress files before uploading the new 2.2 files. If not go back and do that and reupload the files. And do the upgrade again.

    Also, if the database got updated to 2.2 then db_version in wp_option should be 5183.

  4. arm0110
    Posted 9 years ago #

    Thanks MichaelH. I did delete the appropriate files before beginning the upgrade (trying to avoid problems). I will start over and try again.

  5. Lori
    Posted 9 years ago #

    No idea what (if any) plugins you had activated, but I got this same error caused by the King Pages widget. When I deactivated it and went to wp-admin, I got the normal upgrade page.

    Just fyi, I also had trouble with the King Categories widget on another site I just upgraded. I am now using the executable php widget in place of the King widgets.

    Both sites are running on PHP5.

  6. Gersprenz
    Posted 9 years ago #

    I've got the exact same error message when I switched to the famous soleil theme by Avi Alkaley. I use this theme with the WP 2.x Version before with no problems.

    I deactivated all plugins with no effort. Couldn't do anything.

    BUT: When I switched to the WP 2.2 default theme and activate all my plug-ins again everythings is fine again.
    Finally, if I then activate the soleil theme, I've got the same error message again.
    (MySQL 4.0 / PHP 5.0 / WP 2.2).

Topic Closed

This topic has been closed to new replies.

About this Topic