Support » How-To and Troubleshooting » 2.1.1 Security alert?

2.1.1 Security alert?

  • The following, from the Fedora People page:

    “Just spreading the word – WordPress 2.1.1 dangerous – Upgrade! Long
    story short: If you downloaded WordPress 2.1.1 within the past 3-4
    days, your files may include a security exploit that was added by a
    cracker, and you should upgrade all of your files to 2.1.2


    Is this true? I have hacked around with quite a lot of code so am reluctant to upgrade for fear of overwriting my changes. Does anyone know the details of this potential security risk?

Viewing 7 replies - 1 through 7 (of 7 total)
  • shd we consolidate 2.1.1 security ques in a sticky thread?

    As a person ‘hacking’ the core since 0.7 or whatever it was, I’m a believer at this point in leaving the core alone… if only for being able to upgrade easily.

    Otherwise, you should use subversion checkouts, and manage merging/upgrading your changes with changes in the core. That’s one way if you’re hacking around the core a lot.

    I’m a core hacker myself and have the same concerns as siepmann – there’s no easy way to deal with upgrades when you have hacked core files. You just have to create your own system to manage it. But I respectfully disagree with the suggestion of avoiding core hacks. The greatest thing about open source code in general and WP in particular is that you CAN hack it to meet your needs. Have at it…

    i’m surprised i don’t see an official announcement about this in this forum.

    It’s coming.

    Les Bessant


    keeper of the Tiggers

    There’s a sticky post at the top…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘2.1.1 Security alert?’ is closed to new replies.
Skip to toolbar