Support » Alpha/Beta/RC » 2.1 RC1 link/blogroll problem

  • I just tried to upgrade to the 2.1 RC1 but ended up with a blogroll problem that’s returning an error message:

    [Unknown column ‘link_count’ in ‘where clause’]
    SELECT * FROM wp_categories WHERE cat_ID > 0 AND link_count > 0 ORDER BY cat_name ASC

    It initially told me that the link2cat table didn’t exist, so I tried to set it up manually. The error message above is the result from that endeavor. Any ideas on how to fix it? I’m guessing that the link associations didn’t transfer to the new table properly. Would some snippet of SQL code do the trick?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Add one more to this:

    WordPress database error: [Unknown column ‘link_count’ in ‘where clause’]
    SELECT cat_ID FROM wp_categories WHERE category_parent = 0 AND ( link_count = 0 OR category_count != 0 OR ( link_count = 0 AND category_count = 0 ) ) ORDER BY category_count DESC

    Apparently none of my post categories came over, either.

    Help!

    As Moshu explained earlier, 2.1 is not supported in these forums as it is for testers and unreleased but look at default template that comes with 2.1 for answers as 2.1 uses new call for blogroll.

    Trent

    Just log out, log back in and upgrade your database just like you did the first time you installed WordPress. Once the upgrade takes, you’re in business. Also make sure that you have done a clean install. Actually going in and deleting all old files and replacing them with the new content helps.

    The issue is that your database is not being updated. You do not have the 2.1 tables and columns. The database upgrade is triggered based only the installed files and then running upgrade, so be sure that all of the WordPress files have been installed.

    i have the same problem. i deleted all the files on the server (except for config and wp-content) and uploaded all data. i mean i’ve done dozens of updates, so i know what i’m doing, but this time i get the same error over and over. i logged out, logged back in, ran the upgrade script again and still… it’s there. i replaced the tag with the wp_get_bookmarks tag and still! it’s there. and it won’t go away. what do i do?

    This is definitely a problem and has nothing to do with not upgrading since I get the same errors and have now run the upgrade script three times.

    yea, i was upgrading 3 times as well. i got the files deleted first and then put the new ones up. then i got a blank screen. so i re-uploaded the files and overwrote them on the server. now it works but i get this f**k mentioned above. but there are aparently quite a few people out there having this problem.

    I gave up and restored my backups. I will consider upgrading again in a couple of weeks (when all this is hopefully fixed)

    ok… yet another with the dreaded: “WordPress database error: [Unknown column ‘cat_1’ in ‘order clause’]
    SELECT * FROM wp_categories WHERE cat_ID > 0 AND link_count > 0 ORDER BY cat_1 ASC”

    also all my pages are turning up as posts as well, and the categories are not being handled properly… i wish i knew what to fix, cuz i would… gonnah take a look at my copy this week…

    have the following plugins installed:
    ————————————-
    AJAX Comments 2.07
    Akismet 2.0
    Audio player 1.2.3
    Breadcrumb Navigation XT 1.6
    Category Tagging 1.3
    Democracy 2.0.1
    Event Calendar 3.1.0
    Event Calendar Widget 3.1.0
    Flash Tag Cloud 0.1
    Page Category Organiser 2.0
    Quick Stats 1.1
    Random Admin Taglines (Hello Dolly) 1.5
    Related Posts 2.02 + 404
    Ultimate Tag Warrior 3.14159
    Ultimate Tag Warrior: Tag Archive 1.0
    ————————————-

    now i know i am SURE that i could be doing sumptin’ stupid… or am completely missing the issue because i have not looked deeper.

    Same problem, is there any good fix yet?!

    ??

    deleted.

    (I am sorry that I got here from google, didn’t pay attention to that this is about 2.1 RC1 instead of the release…)

    deleted.

    Just try this mysql query

    ALTER TABLE --database--.wp_categories ADD COLUMN link_count BIGINT(20) NOT NULL DEFAULT 0 AFTER category_count,
    ADD COLUMN posts_private TINYINT(1) NOT NULL DEFAULT 0 AFTER link_count,
    ADD COLUMN links_private TINYINT(1) NOT NULL DEFAULT 0 AFTER posts_private;

    work for me 🙂

    worked for me as well, but why isn’t this build into the update script ?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘2.1 RC1 link/blogroll problem’ is closed to new replies.