Support » How-To and Troubleshooting » 2.1 asks me to download PHP file instead of executing action

2.1 asks me to download PHP file instead of executing action

  • I have searched for this but either no one else is having this problem or I just don’t know how to search for this. I am trying to find out if this is a WordPress issue in some way or a server only issue.

    Sometimes, when moderating comments or publishing posts, the site will try for a longer time to do what you’ve told it to do but it can’t and a dialog from FireFox will pop up asking me to download moderation.php or post.php. This does not happen every time and when it does, it’s usually only once, canceling the download dialog and trying again usually sends it through after that.

    Any ideas? I’m running PHP 4.4.4 and MySQL 4.1.21-standard-log.


Viewing 15 replies - 1 through 15 (of 18 total)
  • Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Next time it happens, try downloading the file and then looking at it in a text editor. Often it’s an error message of some sort when this occurs, and this sometimes indicates where the issue is. Usually it’s some kind of server error or misconfiguration or even a transient load.

    Hi there — today I managed to grab a moderation.php and an options-general.php when this happened again. However, both files were completely empty/blank.


    Hi Anela,

    This happens to me a lot. I’m still at 2.0.7 though. I was hoping it would go away at 2.1.

    Anyhow, who is your host? I’m with yahoo (bad idea!) and I think their mysql is to blame. Who knows…

    I’d be checking error logs. Do you have access to ’em with your host(s)?

    What plugins?

    Running out of php max memory?

    So I found a log file called scripts.log

    And it is filled with these:

    [14-Feb-2007 02:25:36] PHP Warning: Unknown(): The session id contains invalid characters, valid characters are only a-z, A-Z and 0-9 in Unknown on line 0
    [14-Feb-2007 02:25:36] PHP Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

    Could this be the reason?

    @ navigadget – I’m with site5.com – looove them.

    @ HandySolo – the only thing in my error_log is two lines where I mistyped a function when making some template changes last night. Here’s a list of my plugins also listed with links here (bottom of page).

    * 404 Notifier
    * Amazon Wishlist
    * AntiLeech
    * AutoLinker
    * Brian’s Latest Comments
    * Comment Analysis
    * Deep Thoughts
    * Extended Live Archives
    * Favatars
    * Flash Filter Plus
    * Google Sitemaps
    * Ma.gnolia
    * Now Reading
    * Owen’s Spam Action (OSA)
    * PXS Mail Form
    * Paged Comments
    * Preview Theme
    * Redirectify
    * Related Posts
    * Role Manager
    * Scrobbles
    * Sociable
    * Subscribe To Comments
    * Text Link Ads v2.0
    * Ultimate Tag Warrior
    * Ultimate Tag Warrior: Tag Archive
    * Viper’s Plugins Used
    * WP Flickr Post Bar
    * WP-Stats
    * WP-UserOnline
    * Weighted Categories
    * WordPress Database Backup
    * XML Parser
    * flickrRSS
    * todayAgo
    * wordTube

    Some of those are new to my site – ie added after this thing started happening.

    In my limited experience, 9 times out of 10 this is a php memory issue. Ask your host(s) to bump the php memory from 8M to 16M. Most hosts will do this no problem.

    … and, just for grins, disable the google sitemap plugin and see if that changes anything.

    How would I find out how much php memory my host allows?…

    Oh wait…I just googled phpinfo and came accross a function called memory_get_usage().

    Now I just have to find out how to run this function. Shouldn’t be that difficult. I’ll update once I do that.

    Handysolo I’ll also try disabling google sitemaps, I have that running too like Anela.

    I don’t think Google sitemaps is making a difference. I’ll be changing my php memory soon. I have to do it myself, according to my host, so have to figure that out (from their faqs).

    Thanks everyone 🙂

    So I looked into phpinfo() output and my hosts allows 20MB memory for php. Is that enough? How can I tell how much resources wordpress and its plugins consume? Maybe I can get rid of the most expensive plugin.

    Any ideas?

    I’m having the same issue in 2.1

    When trying to edit a post I get a blank screen in Safari (or a Download in Firefox) after hitting save. I switched to the Google Sitemaps 3Beta and am not even able to edit posts. I get a ‘lost network connection’ when I click the edit button.

    All problems go away when I dissable Google Sitemap Plugin.

    I didn’t have the issue in 2.0.6.

    Well, that’s strange. If it’s a memory problem, and if I’m reading phpinfo() correctly, then I have 128M of RAM available to PHP … that, and I still get this issue at times, although not nearly as often after the switch to 2.1.

    Yeah, this is definitely a Google Sitemaps problem… that makes me sad. 🙁 I’m not sure if I want to get rid of the plugin, maybe I’ll just have to deal with it…

    I’m having this issue sometimes, and I don’t have the Google Sitemaps plugin.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘2.1 asks me to download PHP file instead of executing action’ is closed to new replies.