Support » Fixing WordPress » 2.0.5 to 2.6 via SQL and posts not recognized

  • Resolved chrisoba


    I have been running 2.0.5 for 2+ years with no trouble but my copy has been heavily modified so I was not able to export any of the data other than via SQL export directly from the database.

    I am currently switching servers so I thought it would be a good time to upgrade to 2.6 and everything seemed to be going well with the SQL insert but out of my 535 posts WordPress only sees 331 and nothing past 11/06/2007 even though the posts are in the database.

    All of the comments are there and show up in the dashboard, but the posts are not seen. I am able to add new posts, and have tried changing my permalink options, but no luck.

    The only thing that changed back around 11/06/2007 was that I changed my category structure and recategorized all of my posts. Could this be causing the problem I’m seeing and what could I do to fix it?

Viewing 6 replies - 1 through 6 (of 6 total)
  • I just upgraded to 2.6.1 and it still only shows 331 of the 535 posts in the database.

    Any ideas on how to force this upgrade?

    Or any ideas on why a post in the database would not be recognized by wordpress?




    lemme guess – you didnt do the upgrades incrementally?

    I just upgraded a 2.1 install to 2.6.1 last night — and in my infinite wisdom tried to do it in one leap. It didnt work out so well, and I had to import in the old SQL dump I took right before starting. Then I did it incrementally

    2.1 -> latest in 2.2-> 2.3.3 -> latest in 2.5 -> 2.6.1

    That worked flawlessly.

    To answer your question, recategorizing and changing your permalink structure would not cause what you are describing.

    ok, that might explain a few things…

    I’ll try transferring what works now and upgrading 2.1-2.2-etc.

    since it’s not live on the new server yet it can’t hurt to play a bit. Thanks for the tip, I’ll let you know how it goes.

    Well I made it to 2.3 but 2.3 has an infinite loop in the admin login which is also the case in 2.5. So I can login but then it just bounces between admin and login over and over again.

    Any ideas on what could cause that?

    The issue with the login loop had to do with the cookies in my browser. Once I manually deleted those I could login to the admin section with no problems.

    So I’ve made it to 2.5, one more upgrade and I’m there. I think this issue is resolved, thanks for your help!

    Also… You can only upload so much data at once (i forget where that’s set, but you might not have access to change it). Any fairly recent version of phpMyAdmin will give you the option to upload the file again, starting where it left off. Totally dope feature. Look closely.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘2.0.5 to 2.6 via SQL and posts not recognized’ is closed to new replies.