Support » Fixing WordPress » 2.0.4 -> 2.0.5 – upgrade.php says not enough memory?!

  • Resolved Eagle

    (@eagle)


    Hey guys! 🙂

    I recently updated my blog to WP 2.0.5 and the update went fine – at least until I executed /wp-admin/upgrade.php, because it says:

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 58368 bytes) in /www/00715/htdocs/wp-admin/upgrade-schema.php on line 326

    So, I asked my web-hoster to increase the memory limit to about 12MB, but he only said: talk to WordPress, they have to reduce their consumption!

    Now I’m on the horns of a dilemma – my hoster won’t increase the memory size and although I’m a PHP-programmer, I don’t know how to fix this.. 🙁

    Any help would be greatly appreciated!

    Thanks in advance,
    Martin.. 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • Alright,

    fixed it by doing a little “cheat”: went to phpMyAdmin, “wp_options”-table, “active_plugins”-option and cut all data inside the “option_value”-cell.

    Afterwards reloaded upgrade.php, updated everything and then pasted the stuff back into the cell.

    Fixed the same issue by increasing php’s memory limit in php.ini.

    memory_limit = 16M ; Maximum amount of memory a script may consume (8MB)

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘2.0.4 -> 2.0.5 – upgrade.php says not enough memory?!’ is closed to new replies.