2.0.4 backup failed with wp-cron (8 posts)

  1. Mn3m0n1c
    Posted 9 years ago #

    Hi everybody,
    I recently upgraded my WP version up to 2.0.4.
    All scripts and plugins works fine, except the wp-cron plugin.

    If I try to backup my database on the fly I haven't problems, mail is immediatly delivered. But if try to schedule the backup i don't receive the e-mail.

    I have this problem since the upgrade from 2.0.3 to 2.0.4
    In order to testing this strange behavior i tried to install a fresh version of WP 2.0.4 in a testing domain, enabling only wp-db-backup and wp-cron, but unfortunately the problem persists.

    Have you some idea or a similar behavior on your blogs?
    Thank's a lot


  2. MichaelH
    Posted 9 years ago #

    Shot in the dark here--any chance it's a permission problem where cron can't write to the folder where it is supposed to dump the backup?

  3. Mn3m0n1c
    Posted 9 years ago #

    The dump file is correctly written on the file system because if I make a manual backup with option send mail, all works fine. The backup file is temporarily written in the backup-xxxx folder, then it is sent by email and destroyed from file system.

    The problem is only the scheduled backup with wp-cron. It's very strange because wp-cron could exec the operations in wp-db-backup, isn't so?

  4. MichaelH
    Posted 9 years ago #

    Can you isolate each of the processes?
    1. Does the backup happen?
    2. Does the email get sent?
    3. Does the backup file get deleted?

    In other words, does any of those three things happen?

  5. Mn3m0n1c
    Posted 9 years ago #

    Yes, just tried this three processes, monitoring in ssh what's happened. Backup is created in folder backup-xxxx, then mail is sent, finally the file is deleted.

    All works fine if I make the backup manually...the problem is wp-cron. I have only wp-db-backup and wp-cron in the folder /plugin.

  6. sdeasy
    Posted 9 years ago #

    I too had this very issue. After much trial and error I eventually solved it. I have blogged about the solution here


  7. starlucent
    Posted 9 years ago #

    Thanks sdeasy - I have this problem too (I hope I can say "had" this problem). Now I just have to wait until tomorrow morning to see if my scheduled backups arrive ...

  8. Mn3m0n1c
    Posted 9 years ago #

    Thank's a lot sdeasy,
    i believe the problem is solved after your precious issue ;-)

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.