Support » Plugin: Braintree for WooCommerce Payment Gateway » 2020 PSD2 Updates

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support vrandjelovic94

    (@vrandjelovic94)

    Hey Albin,

    Vladimir here from SkyVerge, sorry for the late reply.:(

    Yup, we are PSD2 compatible, so this shouldn’t worry you.

    We are already compatible with 3DS2, which allows users to comply with PSD2 regulations in the EU, as Strong Customer Authentication is mandated, and requires 3DS2 to be supported.

    Could you please let me know if there is anything else we can assist you with?

    Cheers,

    Thread Starter Albin

    (@galedev)

    Hi,
    thank you very much for the answer.

    Best regards,
    Albin

    Plugin Support vrandjelovic94

    (@vrandjelovic94)

    Hey Albin,

    You are welcome! I was glad I was able to help here. šŸ™‚

    Cheers,
    Vladimir

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘2020 PSD2 Updates’ is closed to new replies.