WordPress.org

Support

Support » How-To and Troubleshooting » 2.0.2 uploads not working

2.0.2 uploads not working

  • Hi there.

    Maybe it’s a but, maybe it isn’t. But when I try to create a fresh clean installation of the current 2.0.2 release I can do uploads, and I can see them in the upload frame, but when I add them to my post, they don’t show up.

    The .tar.gz file is extracted to /var/www/wptest, so there is a folder /var/www/wptest/wordpress where all the stuff is.

    From the logs of my server I can read:
    [Mon Mar 20 09:23:19 2006] [error] [client x.y.z.101] File does not exist: /usr/share, referer:
    http://xyz/wptest/wordpress/wp-admin/post.php
    [Mon Mar 20 09:34:41 2006] [error] [client x.y.z.101] File does not exist: /var/www/wptest/wp-content, referer: http://xyz/wptest/wordpress/wp-admin/post.php?action=edit&post=1

    The first strange thing is, that it wants to access /usr/share, but I guess that’s another problem.

    The second line tries to access /var/www/wptest/wp-content but it should be /var/www/wptest/wordpress/wp-content.

    I tried to find the reason for this, but I couldn’t find it.

    Help is very appreciated since I really would like to use the 2.0.2 version.

Viewing 7 replies - 1 through 7 (of 7 total)
  • That might depend on how you set the image URL (src). You should always do something like
    http://mydomain.com/wordpress/wp-content/myPicture.jpg
    or
    wp-content/myPicture.jpg

    If you use /wp-content/myPicture.jpg, the browser requests the wrong url …

    Under Options->Miscellaneous I have set “Store uploads in this folder”
    to “wp-content/uploads” and I can also access the images through
    http://xyz/wptest/wordpress/wp-content/uploads/2006/03/whew4.jpg
    But it seems, that if I add the image to my post via drag and drop, it sends the wrong path to the image to the edit field. When I add the image manually with the complete link, it works.

    So, the upload works, also the downloading of the images, but the adding via drag and drop does not.

    Do you have 2.0.2 as well and does it work in your blog?

    Cheers,
    Martin

    I found the problem, but have no clean solution:
    In tiny_mce_gzip.php we have at about line 160:

    document_base_url : “<?php echo trailingslashit(get_bloginfo(‘home’)); ?>”,

    When deleting it all works find. Does anybody have the same issue?

    Cheers,
    Martin

    Same issue here.

    Same issue here, too.

    I think i found problem in WordPress 2.0.2 file upload module. I enable ‘Organize my uploads into month- and year-based folders’ options. So the URL of the uploaded file is with year/month path.

    In wp-admin/inline-uploading.php 260 line:
    $filename = basename($attachment[‘guid’]);
    it’s striping year/month’s path.
    So. I modify the code like this:

    $title = htmlentities($attachment[‘post_title’], ENT_QUOTES);
    $filename = basename($attachment[‘guid’]);
    $filepath = $attachment[‘guid’]; // Add this line.

    in following lines, modify ab[…] = … href=$FILENAME to href=$filepath.

    It’s work correctly now.

    Hi is

    Thanks for the fix …

    I’ve added the line to ‘inline-uploading.php’ but I’m not sure what you meant for the second part … do I replace all instances of $filename with $filepath or do something else?

    Or, is there any chance you could upload your fixed version of ‘inline-uploading.php’ so I/we could download it and see what you’ve done?

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘2.0.2 uploads not working’ is closed to new replies.