2.0.2 Upload Error/Bug (4 posts)

  1. e32o
    Posted 9 years ago #

    I have searched and read every post about this upload permissions problem but noone seems to know the answer to it. Just wanted to ask and see if anyone could help that has figured this out.

    I am running WP 2.0.2 on PHP Version 4.1.2 with MySQL 3.23.58. All seems to be working fine except for the image upload. Everytime i try and upload a image/file i get this error.

    Unable to create directory /home/www/domain.com/wp-content/uploads/2006/05. Is its parent directory writable by the server?

    I have chmod'ed wp-content to 777, I have created a uploads directory in there and chmod'ed that to 777 and still this error. I even tried giving the uploads directory to user apache and still same error.

    Please if anyone has had luck with this I would really appreciate the help.

    Thanks in advance.


  2. Austin Matzko
    Posted 9 years ago #

    It's possible that your PHP installation works under a different user from "apache." One way to find that username is see which one has been assigned to your cache files, if you're using that feature.

    Or you could ask your host.

  3. e32o
    Posted 9 years ago #

    I run my own servers and apache conf files are setup with user "apache". I am thinking it might be a issue not with permissions but with the image module WP is using. I think it needs GD 2.0 or newer, can someone confirm that for me?

  4. Chris_K
    Posted 9 years ago #

    I think it does too, but damned if I can find any documentation stating that right now. But aren't the GD modules included with most php installs these days?

Topic Closed

This topic has been closed to new replies.

About this Topic