Support » Fixing WordPress » 2017 Theme Customizer Won’t Publish

  • Brand new, blank and empty WP site, fresh install of 4.9.4, default theme (twenty seventeen), no plugins enabled. I can’t customize the theme. If I choose a new header image (for example), when I press publish, I get “Looks like something’s gone wrong. Wait a couple seconds, and then try again.”

    Running Chrome, have cleared all the caches, same result. Another admin tries it from a remote location in FireFox, same error. When I debug it in the Chrome Debugger, I see that the call gets a 404 error on http://[site]/wp-admin/admin-ajax.php. But when I run that file from the browser, it finds it, works fine, returns a 0.

    This is hosted on ASmallOrange and they are not helpful. I have other sites on there running other themes with customization options and they work fine.

    Any help?

    • This topic was modified 2 years, 11 months ago by clwill.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator t-p

    (@t-p)

    I noticed that before creating your own post (which is good and we recommend), you also posted in this thread: https://wordpress.org/support/topic/site-wont-save-looks-like-somethings-gone-wrong/page/2/#post-9963160

    My question is: Did yo try all the tips given in that thread? Noting helped?

    I was chastised for posting on that thread. So I came here.

    Yes, I have cleared my cache. No I’m not running any plugins. No, it’s not a mod_security issue (my host tells me they’re not running it, and I’m getting a 404 not a 406). Yes, a health-check is clean. In short, I’ve tried everything there.

    Moderator t-p

    (@t-p)

    That’s good you came here. That’s what we recommend — to star you own thread. That wasn’t the question.

    In short, I understand you have tried everything there and nothing helped.

    In case theme file(s) is corrupted, have tried a different default theme (e.g., 2025, 2016)?

    ugh. so now it works. two days and nothing, now it works. I _do_ have a ticket in with the host, and described the issue in detail. Haven’t heard back, maybe they fixed it?

    But … switched to 2016, tried to customize, it worked. Switched back to 2017 and now it works too. Ugh, I have mystery problems, especially when they “fix” themselves.

    Thanks for your responses…

    O. M. G. Now it doesn’t work again.

    The call to admin-ajax is now returning a 404 again.

    What the heck? Any ideas?

    Moderator t-p

    (@t-p)

    This sounds like a server issue.

    I agree. Of course my host isn’t helpful at all. Time for a new host…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘2017 Theme Customizer Won’t Publish’ is closed to new replies.