Support » Themes and Templates » [Theme: twentytwelve] Featured Image not publishing to world

  • Resolved Sharon Austin


    First of all, I want to say how absolutely GREAT 3.5 and the 2012 theme are…this is a mind-blowing accomplishment, and I absolutely LOVE working with 3.5 and the 2012 theme. Hats off to all in the WordPress team!

    This is a new install, not an upgrade, using 3.5 twentytwelve 1.1. It’s a Multisite set-up; although I have multiple themes, this test uses the unaltered default theme only. I’m able to get a featured image, and have it show up inside the featured image meta box INSIDE a page I’m editing, I’m just not able to “publish” it to the world.

    I see checkboxes, but no option buttons in my set-up.

    What am I missing, or doing wrong?

    Here’s the CODEX pages I’m looking at for guidance:

    According to this page in CODEX, the theme has to support thumbnails

    My functions file seems to be set up as necessary for the featured image–here’s a screenshot:

    I consulted THIS page in CODEX:

    The relevant part from the CODEX is this:

    To show the “Featured Image” meta box in multisite installation, make sure you update the allowed upload file types, in Network Admin, Network Admin Settings SubPanel#Upload_Settings, Media upload buttons options. Default is off.

    Here is a screenshot of the Network Admin, Network Admin Subpanel Uploads Setting:

    Thanks again for any insights you may have.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Have you edited the Twenty Twelve theme in any way? Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    I cannot replicate your issue, so this is specific to your site/install – not the theme itself.

    Could you elaborate or provide a screenshot of:

    I’m just not able to “publish” it to the world.

    I see checkboxes, but no option buttons in my set-up.

    Your files and settings are probably correct.

    Hi esmi, thank you for such an incredibly rapid reply!

    This is strictly unaltered 2012 theme, and actually my second complete fresh re-install, because I was one of those people who had their finger on the button when WordPress 3.5 released, and got one of the non-upgradable 1.1.1 versions.

    This was tested without any plugins, both times (with the 1.1 and the 1.1.1 version of twentytwelve theme).

    Thanks again. If you feel the problem is specific to my site, I’ll try to set up on another somewhere. Best regards and thanks to the team for all!

    The problem may not be specific to your site. There is a bug in WordPress 3.5 with javascript which you might be experiencing others have resolved this by adding define('CONCATENATE_SCRIPTS', false ); in my wp-config.php file just before require_once(ABSPATH . 'wp-settings.php');

    Hi tomontoast,

    Here’s an example of a page in which I uploaded a featured image–you can see that no images show up:

    And here’s a screenshot of what it looks like to me inside the page, where I have taken all the steps for setting a featured image.

    Thanks again for everything! best regards!

    The problem may not be specific to your site. There is a bug in WordPress 3.5 with javascript which you might be experiencing others have resolved this by adding define(‘CONCATENATE_SCRIPTS’, false ); in my wp-config.php file just before require_once(ABSPATH . ‘wp-settings.php’);

    AWESOME! I will pursue that! Thank you so, so much!

    I’ve had a look and can’t work out why you are getting the problem. Maybe try a featured image in a post instead of a page.

    I’ve had a look at the source code of the theme and featured images are only shown on posts not pages.

    Nicely spotted! 🙂

    Okay you two AMAZING people, thank you so, so much! Your knowledge is WAAAAAAAAAAAAAAAY faster than I can test! Woo!

    So, here I am, slowly crawling to catch up! So, two issues, really.

    1. The first issue is that now I know, there’s no problem. If, in the twentytwelve theme, it only works for posts, then so be it. I was ignorant, and thank you for setting me straight.

    For the record, I did try incorporating that code into the wp-config.php file, it didn’t work, so I removed it for that, and for the errors that were showing up in the log when I did so. (But the suggestion was CERTAINLY welcome, and I will always welcome more from you!)

    2. The second issue is my problem–my expectations. I would have assumed if there was a button for featured images in the pages, it would have been there because there was a functionality to support it being there.

    The expectation was there too, because the featured images in pages used to work on my old 3.4 test site, but that was with a 2011 theme, not a 2012 theme. To see an example of “how” the featured image worked, in a page, in 3.4 twentyeleven theme, see this link:

    That image of the woman is the featured image that replaced the header in a page in my 3.4 twentyeleven theme setup. Again, I was expecting the same process to take place in the 3.5 twentytwelve set up. But it’s a different theme, so I should not have expected that.

    All in all, I REALLY appreciate what you do here in the forums! Never let it stop. Thank you, thank you, thank you! Take care.

    It obviously is a problem that you expect featured images to work on pages if it tells you on the admin screen you have a featured image. The problem is wordpress can’t tell what the content of each theme template is so can’t tell you if a certain feature will work or not. This is a feature which could be incorporated into future releases but there probably just needs to be clearer documentation.

    tomontoast, all I know is that your help is AMAZING!

    Since even your last comment, I have learned so much….I have gone to the CODEX, with the feedback you have given me, and found so much information, it is incredible. I think I know what to do to get the featured images to work, if I so desire, because of your feedback.

    add_theme_support( ‘post-thumbnails’ );
    add_theme_support( ‘post-thumbnails’, array( ‘post’ ) ); // Posts only
    add_theme_support( ‘post-thumbnails’, array( ‘page’ ) ); // Pages only
    add_theme_support( ‘post-thumbnails’, array( ‘post’, ‘movie’ ) ); // Posts and Movies

    All I have to do is add theme support. (Not going to test today, though) I would not have been able to do it without your (and all the team’s) feedback. Thankyou, thank you, thankyou.

    Keep it coming.

    Using add_theme_support( $feature ); will tell wordpress what features the theme or plugin can support but this won’t update what the theme is actually able to do. To get featured images to work on a post you will need to edit the theme and add the_post_thumbnail();

    However you have led me to discover the bug in the 2012 theme it should have:

    add_theme_support( 'post-thumbnails', array( 'post' ) );

    instead of

    add_theme_support( 'post-thumbnails' );

    @tomontoast: Can you post that in Trac?

    @esmi I don’t have access to the theme Trac.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Theme: twentytwelve] Featured Image not publishing to world’ is closed to new replies.