Support » Themes and Templates » 2010 Weaver Support

Viewing 15 replies - 16 through 30 (of 49 total)
  • Happened to me too. Upgrade seems to delete the contents of the theme directory without installing the new files. Not sure why it’s doing this, corrupt file in WordPress repository or whatever I guess, but got error messages in Dashboard and a blank index.php page :o(

    About failed upgrades:

    Something has definitely screwy has been happening with the WordPress.org servers and 2010 Weaver 1.3.1. The theme was approved, and has the correct files, but for some reason, has (seemingly randomly) been generating incorrect .zip files – has many missing files, and apparently not the same set of file.

    Please note that this is some kind of (temporary) WordPress fault, and is beyond the control of the 2010 Weaver Theme itself. The WordPress theme repository has a correct set of files, it is just delivering the wrong set for download or update.

    You can always go to http://wpweaver.info for the latest version to download. Just delete the current version from the dashboard, then reinstall the version from the .zip you download. Your settings will all be fine, and still there.

    I am looking for a way to remove titles from static pages within Weaver, such as desribed here: http://forum.bytesforall.com/showthread.php?t=1334

    ??

    2010 Weaver is a child of WordPress ‘twenty ten’, you could try this

    HTH

    David

    How to do this is already included in the CSS snippets included with 2010 Weaver:

    If you want to hide the title of a specific page, you use the WP ID of the page (both posts and pages have ids – you can get the page id from the Edit Page/Post address bar – it will show as ?post=id). To hide a specific post or page, use this (this example will hide the title of page with id=3, you have to determine the id of the post/page whose title you want to hide):

    #post-3 .entry-title{display:none;}

    How to do this is already included in the CSS snippets included with 2010 Weaver

    Great for single posts or pages but this is a common request that comes up daily, turning off the post title on all pages not posts.

    If someone has a lot of pages a nightmare, if the theme is supplied to a third party you cannot tell a client to edit the style.css evry time that add a page.

    So for those editing page.php and adding a style may be an cleaner option for some, or a new theme option 🙂

    <?php if ( is_front_page() ) { ?>
    	<h2 class="entry-title" style="display:none;"><?php the_title(); ?></h2>
    <?php } else { ?>
    	<h1 class="entry-title" style="display:none;"><?php the_title(); ?></h1>
    <?php } ?>

    B.T.W.
    I just downloaded 1-3-2 from your website, and all that is in the zipped folder is one file, ‘twentyten-weaver-1-3-2’ 968kb with no extention, it is the zipped files without the extention?

    David

    Actually, turning off the title of all static pages can be done in the Weaver theme using:

    #content h1.entry-title {display:none;}

    Posts titles are h2, so they won’t be hidden.

    —–
    And I don’t know what is going on with your download from the site. I just downloaded to both a Mac and a Win7 machine, and the zip file unpacked fine. Perhaps some temporary file issue. I did switch hosts last week, and there may have been a small window when various DNS servers were out of sync. Sorry if that caused issues, but it is not very easy to try to switch hosts for a live site.

    I need to upgrade to the latest version but can not figure out how to make a child a child theme. I had to modify some of the CSS and if I upgrade I lose all of my changes.

    To add numbers to my comments I’d preferably like to use Greg’s Threaded Comment Numbering. But after having installed the particular plugin I found out that it only seems to work on default themes. Can this be solved and if not is there another way to add numbers to comments?

    I am having trouble with the sidebar widgets in the 2010 theme. I am able to configure and display widgets in all areas except the primary & secondary (sidebar) areas. Any ideas on why this is happening? Here is a link to my site
    http://foggydazedelivery.com

    @bmurphy000:

    You’ve either picked no sidebars from the Main Options panel, or you’ve used the .one-page template when creating your pages.

    @tboard:

    You should really never have to modify CSS files. You should use the <HEAD> Section on the Advanced Options tab to over-ride CSS rules. Then you won’t lose anything when you upgrade.

    @tommyuniverse:

    I will have to check this out. Please add a post to http://wpweaver.info/forum to get a follow up.

    No I should not have had to modify the CSS but I chose a dark theme and the comment section turned out to be white on white. There wasn’t any other way to fix it.

    The site is at stpaulphotos.com. It has one sidebar to the right. When I tried making a childtheme the footer ended up on the top of the site.

    Sorry for the simple question, but in response to the hiding titles, where exactly do I put the code?

    Either

    #content h1.entry-title {display:none;}

    or

    #post-3 .entry-title{display:none;}

Viewing 15 replies - 16 through 30 (of 49 total)
  • The topic ‘2010 Weaver Support’ is closed to new replies.