Support » Plugin: WP Video Posts » 200, Stream not found, NetStream.Play.StreamNotFound, clip: '[Clip] …

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author AlexRayan


    Hi Pfeffi,

    When one gets 200 stream not found from the flowplayer, it most likely means that the video is not found and is not on the server.
    Are you able to see the video if you copy paste the link from the shortcode to the browser?
    In not, then make sure you are able to upload other media and files (pictures, docs) to the server through media uploader (Go to Media Library directly and try uploading the same video, for example).
    It might be permission issues on /uploads/ directory if you won’t be able to upload files through the media uploader directly.
    Also, do you have ffmpeg installed on the server? Are you converting videos to different format or you’re just uploading videos with mp4 extension?
    If you don’t have ffmpeg installed and are uploading videos with extension other than mp4, they won’t be playable through the flowplayer that is in the player used in our plugin.

    Hope this helps.

    Best regards,

    dear alex,

    thax for answering. i have a generel question – is your plugin – wp video posts – appropriate to build a video site youtube-style on wordpress?

    what your tipp belong to: yes i have ffmpeg running on my server. after the upload i can see the slashpicture … but the video has the same error-message than bevore 🙁

    i tried to upload from backend and with the frontend uploader – same result 🙁

    but you’r wright – i can not find the video file in the upload-directory on my server … what could be wrong?

    thx so much for your help!
    best regards from tirol,

    okay … some new information about my problem:

    after 10 minutes i can see the first video as a file in the upload directory (also the slash-jpeg)
    but only the .mov-file … shouldnt it be converted to mpeg4 or so?

    an a cannot play the videofile anyway (copy past to the browser)

    ah ja alexa – may be its usefull for your answer?

    i use pacifichost for to be able to use your plugin and they told me, that ffmpeg is installed. do i have to configure anything on ffmpeg or is it done, if it’s installed?

    best regards

    Plugin Author AlexRayan


    Hi Pfeffi,

    To answer you questions:
    – yes, the plugin would be appropriate to build a youtube-like site and I have used it before for this purpose. It might require certain tweaking of the template files to fetch the list of videos by category and by author and, in case you have buddypress installed, there will be more tweaking of buddypress templates as well.

    – regarding the files not being there. It looks like they are either not being encoded (ffmpeg issue) or not being saved (permission issue).
    You can test both issues if you have ssh access to the server.
    Try to run the following command from the terminal where is a path to the file to be encoded.
    For example, since we are testing wp-content/uploads/2013/02/, go to wp-content/uploads/2013/02 directory and copy the original file there.

    ffmpeg -y -i -acodec libfaac -vcodec libx264 -f mp4 -vtag avc1 -vpre normal -refs 1 -coder 1 -level 31 -threads 8 -partitions parti4x4+parti8x8+partp4x4+partp8x8+partb8x8 -flags +mv4 -trellis 1 -cmp 256 -me_range 16 -sc_threshold 40 -i_qfactor 0.71 -bf 0 -g 250 targetfile.mp4

    If ffmpeg is working fine and there is no permission issue, you should be able to see targetfile.mp4 created in /2013/02/ directory.
    If not, you would see some error response which would probably draw the light on the issue.

    Hope this helps and please let me know if you are able to test it.

    Best regards,

    thx alex!

    do you also support on customers servers directly?
    and may be you have some links for me, to see, what you had made out of this plugin?
    best reguards

    hi alex,
    now i installed a different plugin – this plugin also uses ffmpeg …
    this plugin has a status-tab and it told me that ffmpeg is not installed.
    after i changed the path, it said, ffmpeg: installed

    may be i have to change the path to ffmpeg in your script?

    best reguards from tirol 🙂

    hmmm … a splash-image was created …
    but i can not start the video …
    the player is where he should be …
    but when i trie to start, e get 200, Stream not found, NetStream.Play.StreamNotFound, clip: ‘[Clip] …

    Plugin Author AlexRayan


    Hi Tirol,

    Yeah, you can definitely try to change ffmpeg location in the plugin and see if it helps.
    We didn’t specify any location to call ffmpeg since one is usually able to call “ffmpeg” directly from command line without a pass.
    But if you would like to try with the pass here is where you can change it:
    line 229:
    $str = "ffmpeg -y -i ".$source." ". $extra ." ".$target;

    You can put the path before ffmpeg call as such /usr/local/lib ffmpeg
    And line 282:
    $str = "ffmpeg -y -i ".$source." $extra ".$target;

    Plugin Author AlexRayan


    This is my email:
    Could you please provide me a url to your website so I could take a look at it?

    did not work 🙁

    would you like to check/fix it on my server?
    i would write you under your mail-adress from your website to give you access?!

    Plugin Author AlexRayan


    Whoever is interested in the above solution:

    every ffmpeg installation various in a way it was complied.
    If the thumbnails are being generated for you while the video is not being encoded and saved (you get 200 error finding stream of the flowplayer and you cannot see the files on the server), please try editing line 283 of code in wpvp-functions.php

    BEFORE: $str = "ffmpeg -y -i ".$source." $extra ".$target;

    AFTER: $str = "ffmpeg -y -i ".$source." -acodec libfaac -vcodec libx264 ".$target;

    Practice shows that if ffmpeg is missing presets that are used in the $extra variable the encoding “silently” fails without leaving any trace in error logs.

    The above basic command line is enough to encode the video, however, if you would like to have a better quality / size ration produced, we would strongly recommend going over each present and flag in the $extra variable and enabling / adding the presents to your ffmpeg installation.

    Best regards,

    I was suffering this very same symptom. The first thing I did of course, was to check that the actual target video was present, and tested it directy. It worked. As often the case in looking for a solution with a WP issue, I came here.

    In short, after trying many things, I discovered that the problem with flowplayer was actually caused by a theme that I just installed, Itheme2. Reverting to my previous theme fixed the problem. I don’t know why it, and Flowplayer don’t want to play toghether, but I wish I did.

    Plugin Author AlexRayan


    Hi Pixelreffic,

    Sounds like a javascript issue.
    The plugin is using both hooks to add the required scripts: wp_head() and wp_footer(). It also need for jquery to be enqueued in the head.

    Have you checked whether these two hooks are present in the theme’s header.php and footer.php respectively? Or whether the theme is deregistering jquery and registering its own version by any chance?

    Hope it helps.

    Best regards,

    Thanks for the response Alex. I should have noted that I’m using the “Secure HTML5 Video Player” plugin. It’s actually taking care of inserting the script. I then just call the video with a shortcode. Very handy, but clearly doesn’t work correctly with the itheme2 theme.

    I might however try disabling the plugin, and manually adding the script calls in the theme header and footer.

    As to how this theme handles jquery, I’m afraid that’d a bit over my head. 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘200, Stream not found, NetStream.Play.StreamNotFound, clip: '[Clip] …’ is closed to new replies.