WordPress.org

Forums

Customizr
[resolved] 200 pages from my Menu are gone (12 posts)

  1. Mary3485
    Member
    Posted 8 months ago #

    Hi, I tried to add one more page to my child menu and after SAVE all my pages were gone (on the menu). I had more than 200 pages there and now all is missing. I am using a child theme and when I try to add them again it does not allow me to add any more pages than the ones left after I hit SAVE.
    The website is http://www.oplakvaniq.com
    Please advise me.

  2. ElectricFeet
    Member
    Posted 8 months ago #

    This is a long-standing server issue: https://core.trac.wordpress.org/ticket/14134

    Contact your site hosts and point them to that ticket.

  3. acub
    Member
    Posted 8 months ago #

    Actually, all you need is WP MSP. I had a similar problem when sending more than 100 variations of a woocommerce product but it worked after I maxed the limit to 2000 variables.

    The real nasty part about this error is that it's completely silent. Just dies without a log, without a warning, like everything worked as expected.

  4. ElectricFeet
    Member
    Posted 8 months ago #

    Good tip, thanks acub. Yes, that was one of the things raised in the (log) ticket: at least it would be better to give some sort of error message.

  5. Mary3485
    Member
    Posted 8 months ago #

    Thanks i'll try that.

  6. Mary3485
    Member
    Posted 8 months ago #

    This is what my host replied:
    And they say they should back up the site, can not fix the issue, can you advise if this is true?
    Can I change it by myslef? And where from?
    Quote:
    whereas it's suggested to use register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_execution_time = 600
    max_input_time = 600
    memory = 20MB
    memory_limit = 256M
    variables_order = "EGPCS"
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
    (9:09:11am)John H.:This is not possible on shared servers

  7. ElectricFeet
    Member
    Posted 8 months ago #

    Try the plugin that acub suggested and see what happens.

    As to a backup, well, you should always keep an up-to-date backup. There are various plugins for this. Find one you like.

  8. Mary3485
    Member
    Posted 8 months ago #

    I already installed the plugin. It shows this message

    This form has too many fields (1010) for the server to accept (max 1000)
    Data may be lost if you submit. Are you sure you want to go ahead?

    I have tried manualy to edit the file php.ini in the hosting but till now without any sucsess.These are the default settings in the begining of the file.

    This is the default settings file for new PHP installations.
    ; By default, PHP installs itself with a configuration suitable for
    ; development purposes, and *NOT* for production purposes.
    ; For several security-oriented considerations that should be taken
    ; before going online with your site, please consult php.ini-recommended
    ; and http://php.net/manual/en/security.php.
    suhosin.post.max_vars = 3000000
    suhosin.request.max_vars = 3000000
    date.timezone = America/Chicago
    max_post_size = 300000

    Thanks

  9. Mary3485
    Member
    Posted 8 months ago #

    I have tried also to add this

    <IfModule mod_php5.c>
    php_value max_input_vars 5000
    </IfModule>

    to my htaccess folowing the instructions in
    http://wordpress.org/support/topic/menu-item-limit-1?replies=21
    Still can't add new pages to my menu.

    Also found this very useful article
    http://sevenspark.com/wordpress/menu-item-limit

  10. acub
    Member
    Posted 8 months ago #

    You should consider dropping the last level of your menu and displaying those pages as a submenu/list on their parent page only. 200 items in a menu is a bit much. What happens when someone opens that menu on a mobile device?

  11. Mary3485
    Member
    Posted 8 months ago #

    Till yesterday i had around 45 pages in that menu. And with the subpages all was 402 pages. All was working fine till that new page i decided to add. I will contact the host again today to ask them to change this to 6000. Will that be ok for my 402 pages
    suhosin.post.max_vars 6000
    suhosin.request.max_vars 6000

  12. Mary3485
    Member
    Posted 8 months ago #

    The problem was in php.ini file
    suhosin.post.max_vars
    suhosin.request.max_vars

    the host fixed rased the number.
    Now all is okay thanks :)

Reply

You must log in to post.

About this Theme

About this Topic