Support » Alpha/Beta/RC » 2.0 RC2 Backup failure

  • Backing up never completes. It usually hangs at “Backing up table “wp_categories”…” somewhere around 8-17%.

    It looked like it completed when selcting to save to server, however this was not the case. All attempts to backup, either to download, server, or email failed to complete.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Backing up What ? How ?

    Sorry, using the 2.0 RC2 included WordPress Database Backup plug-in.

    I have the same problem except it never seems to start. Just sits there.

    Please – lots of details:
    OS
    browser
    server
    host
    versions, etc etc etc
    you cannot give too much info.

    I am on an iMac, V10.4.4, using Safari and Firefox. I think the server I am on is Unix/Windows hybrid but I do not know for sure.

    PHP version 4.4.1
    MySQL version 4.0.25-standard
    PERL version 5.8.6

    I am using v1.7 of the plugin supplied with RC2.

    I also have tables that other plugins created, so when I backup I select those. For a test, I deselected those and ran the backup and it worked as expected.

    The website it is hosted on is: http://www.sbishere.com/

    Is there any more information you would like?

    Using Debian GNU/Linux (Unstable) with Firefox 1.0.6 and a freshly updated SVN checkout of WordPress 2.0, I was able to successfully backup the core database tables.

    I was also able to successfully backup the core tables, plus the single non-core table in my test database.

    Viewing with:

    Firefox 1.5 on Windows XP

    Site Info:
    Operating system Linux
    Kernel version 2.4.21-32.0.1.ELsmp
    Apache version 1.3.34 (Unix)
    PERL version 5.8.1
    PHP version 4.4.1
    MySQL version 4.0.25-standard

    Running WP 2.0 RC2.

    When I run the WP DB Backup it startes but usually “hangs” at some point. When I chech the server, there are actaully files created by it in the folder it created. This is regardless of if I’m telling it to email, downloag, or saver save the backup file. It always saves to the server regardless of selection.

    Site is hosted on http://www.hostingforabuck.com

    The plugin, by design, stores temporary files in the backup directory. When it has successfully delivered the file to you, it cleans up after itself.

    How big is your database?

    Skippy:

    mysql database is 0.80 Megabytes

    For what it is worth, I just upgraded to 2.0 RC3 and this fuction is operating correctly for all options.

    I’m using 1.7, and I’ve found that having other tables with hyphens in their names causes the backup utility to hang at the start because of a Javascript error (which is made my the output of MySQL error). I fixed this, by changing line 200 from this…

    $rec_count = $wpdb->get_var(“SELECT count(*) FROM {$table}”);

    to this…

    $rec_count = $wpdb->get_var(“SELECT count(*) FROM {$table}“);

    and line 497 from this….

    $table_data = $wpdb->get_results(“SELECT * FROM $table LIMIT {$row_start}, {$row_inc}”, ARRAY_A);

    to this…

    $table_data = $wpdb->get_results(“SELECT * FROM $table LIMIT {$row_start}, {$row_inc}”, ARRAY_A);

    However, now it’s haning at 95% of the backup.. so part of the solution is in there, but I haven’t dug down to the last fix.

    Nick Sterling
    Indiana University Bloomington

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘2.0 RC2 Backup failure’ is closed to new replies.