WordPress.org

Support

Support » How-To and Troubleshooting » 2.0 Import from MT problems

2.0 Import from MT problems

  • I tried using import from RSS, then I remembered that my rss doesnt have any comments in.

    I have exported from MT using the old method and created a text file. Then I imported using the new import from MT option in the 2.0 admin, but it only imported the posts and no comments. Ive checked the import textfile and the comments are there.

    Any suggestions? Thanks

Viewing 15 replies - 1 through 15 (of 30 total)
  • Any ideas anyone?

    I’m having the same problem. I get the screen which tells me all the new authors to be added. But they’re not added — nothing is added to my database. Though I do see the imported files in the wp-content directory.

    I was really hoping to move all our MT blogs over to wordpress during the winter break while no one at my company is posting to them. ><

    Does anyone have a solution to this? Comments are quite important and I don’t want to go back a version of WP.

    Thanks

    I don’t have a solution either, and I’m having the same problem.

    Has anyone used the MT import link successfully? Or are people importing their posts via RSS feeds?

    Sorry guster and thaleia…I haven’t been able to get it to work either. But, actually, my problem is a bit different than yours.

    I get this when I try to upload:

    Unable to create directory /home/virtual/site420/fst/var/www/html/blog.joelmaust.com/wp-content/uploads/2005. Is /home/virtual/site420/fst/var/www/html/blog.joelmaust.com/wp-content/uploads writable?

    In reading these forms, my problems sound similar to the problems people are encountering with the file uploader. I don’t know alot about this technical stuff…but it doesn’t seem to matter what chmod permissions are set to…I can’t get it to create the directory tree for the entries I want to import.

    Looks like it might have something to do with the ownership of the created directories belonging to apache|apache rather than my admin…but I don’t know for sure.

    I’m having the exact problem as you, Christoper. Has anyone found a solution or workaround?

    Okay… I’ve spent an hour or two looking at this, and the problem is not that it doesn’t import the comments – it does. The problem is that it imports them unapproved, and the only way to approve them is to manage posts -> click on the “0” comments and you can see them there.

    I can’t find a way to mass approve the comments, since they don’t show up in the “Moderate” section.

    Alright. Here’s a fix, but it will be messy as hell, because I know NOTHING about PHP.

    In wp-admin/import/mp.php, go down to the part under “//Now for comments” where it says “//Check if it’s already there”

    Replace what’s there with:

    // Check if it’s already there
    $comment_approved = “1”;
    if (!comment_exists($comment_author, $comment_date)) {
    $commentdata = compact(‘comment_post_ID’, ‘comment_author’, ‘comment_author_url’, ‘comment_author_email’, ‘comment_author_IP’, ‘comment_date’, ‘comment_content’, ‘comment_approved’);

    This basically sets “comment_approved” to “true” and then imports it into the database with that value, where it was blank before.

    Try it, but don’t blame me if it makes things blow up.

    I just ran an MT import into 2.0 for a client and ran into the same issue with the comments.

    The comments do get imported – however the comment_approved field database table is blank. They are not marked as approved, unapproved or spam – it’s just blank. Unassigned.

    Quick fix? Run a SQL Query via phpMyAdmin (or your choice.) Here’s what did it for me:

    UPDATE wp_comments SET comment_approved = ‘1’ WHERE comment_approved = ”

    Fixed it right up – all comments and trackbacks are present an accounted for.

    It’s definitley a bug, though, that needs fixing. I can’t tell you how many clients I do MT to WP imports for on a regular basis. Ugh!

    Thanks that was exactly it!

    Thanks LisaS but an issue came up with that.

    I imported the entries, no comments showed up, I ran your SQL query and although it lists the comments, when you look at the template it says NO COMMENTS, and when you “Manage -> Posts” it keeps a 0 in the comments field.

    Is there any other way to fix that?

    Lisa’s solution should have worked. If you’re showing 0 comments, but you can still see them when you click that zero, then they’re still in approval limbo. Check your database to see what the approval status is. 0 is unapproved, 1 is approved, and nothing means that the query didn’t work properly.

    I spoke too soon, like Krissy I have the same problem. In the database all of my comments are set to 1 (approved), but although they show up on the site, it still says no comments on the link and at the top of the comments section.

    Looking at wp_posts in the database, the comment_count field is empty, this is because we only changed the status in the comments table and didn’t alter the posts table to show how many comments.

    Anyone got an idea for a php script or sql query that will go through the posts table then pull out the number of comments from the comments table for that post id?

    I have found a solution!
    Instead of making the comment_approved field to ‘1’ change them all to ‘0’, that is,

    UPDATE wp_comments SET comment_approved = ‘0’ WHERE comment_approved = ”

    Then they will all appear in the “awaiting moderation” section, then do a approve all! All my 2000 comments appears in the post with the comment count correctly showing in every post!!!

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘2.0 Import from MT problems’ is closed to new replies.