Support » Fixing WordPress » 2.0: Editing published post in admin redirects me to blog

  • Resolved eveums

    (@eveums)


    In the Admin area, when I select Manage – Posts and choose to Edit a previously published post, I go briefly to the Edit screen, and then I am directed immediately to the published post on the blog. Same thing happens if I choose to “Edit” the post from the blog view [i.e. by selecting the “edit post” option]. I’ve tried this using several different templates.

    Any help would be appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Any chance you’re using a “framebuster” plugin or bit of javascript? If so, this is the cause.

    The Preview Post area of the edit page actually loads a complete copy of the post, templates and all, including any framebusting js.

    Thanks. I was using Denis DeBernardy’s FrameBuster plugin; deactivating it seems to work.

    I have been using this plugin for a long time now, with no problems. I gather that 2.0 loads post information differently than did 1.x versions…?

    Just look at the Preview Post area. In a very large way, it does load post information differently.

    suture

    (@suture)

    aaah got me as well. I had the following javascript in the header.php

    <!–

    if (top.location != self.location) {
    top.location = self.location
    }

    –>

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘2.0: Editing published post in admin redirects me to blog’ is closed to new replies.