Support » Installing WordPress » 2.0 and the death of my permalink structure

  • Resolved danweasel


    Sorry to add to the number of posts complaining about broken permalinks, but I’m going to explain the specifics of my issue in the hopes that someone will take notice or that they will help contribute to improving the code.

    I just completed upgrading to 2.0 and switching servers with no problems until adjusting permalinks, which is typically one of the last things I do after moving a WP install. The first thing I noticed was that the .htaccess file was considerably smaller than it had been in 1.5.x:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php

    # END WordPress

    Then when I tried clicking through to a specific post, I noticed that all single post/category/archive/page permalinks weren’t working. I tried upgrading functions-post.php and classes.php to the new versions Ryan mentioned in this thread, but nothing changed.

    I also installed the Dump Environment plugin and saved the resulting source of the front page here.

    I have verified that mod_rewrite is loaded in Apache’s config file.

    If I can provide more information about this problem I would be glad to; I’ll keep monitoring the support forums but will greatly appreciate anyone who can help me out.


Viewing 14 replies - 1 through 14 (of 14 total)
  • I think that this problem has been solved in the latest download. Did you install 2.0 from a fantastico script or something like that?

    If so the code may be behind the latest downloadable. If this is the case you might like to try downloading the latest code. Delete the /wp-admin/ and the /wp-includes/ folder on your server then upload the latest folders from the latest downloadable.

    Then try updating the permalinks again.

    I’ve had the problem in both 2.0 and 2.0.1 rc1.

    check the “Custom, specify below “, and make the form like “/index.php/%post_id%/”, hope it helps.

    Isn’t using index.php in the permalink a workaround for those without access to mod_rewrite? It is enabled on my server so I ought to be able to use .htaccess to have real permalinks.

    The first thing I noticed was that the .htaccess file was considerably smaller than it had been in 1.5.x:

    Search around a bit. What you have is intended.

    In pre-2.0, mod_rewrite would decode the URLs and then pass them off to WordPress’ index.php file with variables like this (made up, but you get the idea): index.php?year=2006&month=01&day=28&slug=test+post

    Now, all permalinks are simply handed directly off to WordPress which decodes the requested URL itself. It’s much better this way, when it works that is (and it should).

    Dunno why it isn’t for you though. Have you clicked “update permalink structure” on your options page (you don’t need to change anything, just click the button).

    I figured that it was intended behavior–it is a much nicer looking file than before. I’ve clicked “update permalinks” and all with no luck.

    I’ve actually just tried using an old 1.5.2 zip file to install that version of WP and the permalinks don’t work there either, which I can only assume means there’s an issue with the new server.

    Apache does load rewrite_module and does exist in the filesystem, so I’m not certain where the problem might be. I’ve emailed my host and hope to get a response back.

    Thanks for all the help offered.

    Couple things —

    1. Is your WordPress bit in the .htaccess on the absolute bottom of the file? This was a consistent problem.
    2. More obvious: your main index is index.php, right?

    WP is the only item in .htaccess

    And yes, index.php is the main index. Nothing fancy here, just a regular WP install.

    Huh. Just got a response from my host saying that there weren’t any apparent issues with apache/mod_rewrite, as it had appeared to me before. They didn’t say they changed anything, but now permalinks are being properly generated.

    Go figure.

    I still wish I knew what the error was, but I’m mostly just happy to have WordPress working properly.

    Thanks for the help all.

    Would you consider this topic resolved then? If so, could you change the dropdown accordingly? Thanks!

    [Nev’mind, I see you’ve just done so, thanks again!]

    I’ve posted regarding this problem as well and now that mine is working I thought I’d add to the data. I don’t know if it’s pertinant or not, but once I switched from FileZilla to Bulletproof, for uploading WP 2.0 files to the server, all my problems went away.

    I did four complete installs and each time I had problems with permalinks. On the fifth attempt, using Bulletproof this time, but otherwise the identical setup, everything worked.

    Vexed in Fernie…

    Since I just went down this road with a new host (well, MY new host, but still…) perhaps I can make a guess as to what your host changed.

    From the Codex:

    Scroll down a bit to the Fixing Other Issues section. I’ve noticed that my last few RedHat (FC and CentOS) installs don’t have:

    AllowOverride All

    on by default. Perhaps your host didn’t either? It’s one of those quick “forehead slap” type fixes…

    Yup that was it. In fact I went to check a little while after I’d sent an email to my host asking about mod_rewrite to find AllowOverride set to All, and permalinks mysteriously working. He confirmed later that he had changed it just then.

    RH based distro too…hmmm.

    🙂 Good deal. I got bit by that one twice this weekend on two different servers. One FC4 and one CentOS4.something

    (yeah, I’m the guy that keeps hitting his head on the same light in the attic. never learn…).

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘2.0 and the death of my permalink structure’ is closed to new replies.