Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » 2 sites down after 6.1 wordpress upgrade

  • Resolved Hal Sclater

    (@hsclater)


    So 2 sites auto upgrade to 6.1, since then they are broken with error:

    There has been a critical error on this website.

    This happened at the same time since they both decided to upgrade at the same time. I will be disabling auto update on all my other sites. Yes I do have backups but would rather fix.

    https://historylive.co.uk
    https://caragyoga.com/

    The email says:
    In this case, WordPress caught an error with one of your plugins, Jetpack.
    WordPress version 6.1
    Active theme: Hello Elementor (version 2.6.1) Current plugin: Jetpack (version 11.5) PHP version 8.0.21

    An error of type E_ERROR was caused in line 2 of the file /home/historylive.co.uk/public_html/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-waf/rules/rules.php. Error message: Uncaught Error: Failed opening required '/home/historylive.co.uk/public_html/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-waf/src/../rules/allow-ip.php' (include_path='.:') in /home/historylive.co.uk/public_html/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-waf/rules/rules.php:2
    Stack trace:
    #0 /home/historylive.co.uk/public_html/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-waf/src/class-waf-runner.php(176): include()
    #1 /home/historylive.co.uk/public_html/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-waf/src/class-waf-runner.php(48): Automattic\Jetpack\Waf\Waf_Runner::run()
    #2 /home/historylive.co.uk/public_html/wp-content/plugins/jetpack/modules/waf.php(30): Automattic\Jetpack\Waf\Waf_Runner::initialize()
    #3 /home/historylive.co.uk/public_html/wp-content/plugins/jetpack/class.jetpack.php(1862): include_once('...')
    #4 /home/historylive.co.uk/public_html/wp-includes/class-wp-hook.php(308): Jetpack::load_modules()
    #5 /home/historylive.co.uk/public_html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()
    #6 /home/historylive.co.uk/public_html/wp-includes/plugin.php(517): WP_Hook->do_action()
    #7 /home/historylive.co.uk/public_html/wp-settings.php(480): do_action()
    #8 /home/historylive.co.uk/public_html/wp-config.php(101): require_once('...')
    #9 /home/historylive.co.uk/public_html/wp-load.php(50): require_once('...')
    #10 /home/historylive.co.uk/public_html/wp-admin/admin.php(34): require_once('...')
    #11 /home/historylive.co.uk/public_html/wp-admin/index.php(10): require_once('...')
    #12 {main}
      thrown

    Also recovery link in the email doesn’t work and says: Recovery Mode not initialized.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • koladblog

    (@koladblog)

    Same with my website now https://myseonote.com

    Please find something to do to this error

    Moderator Marius L. J.

    (@clorith)

    @hsclater this appears to be a fatal error within the Jetpack plugin, so I’ve moved your support request to their support forums.

    @koladblog Your issue is also originating within Jetpack, but it is not the same problem, I would recommend you open your own support topic within the Jetpack support forums.

    Plugin Support Daniel (a11n)

    (@ihenetudan)

    Hi @hsclater,

    Sorry for the inconvenience there. We are aware of the issue and working on a point release (11.5.1) to fix it. It should be out in the next 24 hours.

    In the meantime, removing and re-installing Jetpack 11.5 or deactivating and reactivating the WAF module via WP CLI will fix the issue. There’s more information about this here.

    Thanks for your patience.

    Thread Starter Hal Sclater

    (@hsclater)

    Yep now my other sites are dropping like flies. I’m not in a position to login and fix it either, multiple sites offline now, nightmare.

    tomigco

    (@tomigco)

    It’s not Jetpack in my opinion. My store was down and I had to rollback PHP to 7.4 because a swatch plugin was killing the site completely when doing the latest update. Jetpack was fine. BUT, I now have three other sites that have been upgraded to 6.1 and I can’t get in to admin. All three are BeTheme and not stores.

    And we get no error messages in the logs.

    tomigco

    (@tomigco)

    BeTheme identified they found an error with the 6.1 update. I had to download the theme and replace it via FTP per BeTheme. Wonderful. Ugh.

    kottanz

    (@kottanz)

    The website is down after updating 6.1

    https://haloocom.com/
    Can Anyone help

    Error

    Warning: require(/home/z6kmqmxpi9ug/public_html/wp-includes/class-wp-theme-json-data.php): Failed to open stream: No such file or directory in /home/z6kmqmxpi9ug/public_html/wp-settings.php on line 176
    
    Fatal error: Uncaught Error: Failed opening required '/home/z6kmqmxpi9ug/public_html/wp-includes/class-wp-theme-json-data.php' (include_path='.:/opt/alt/php80/usr/share/pear:/opt/alt/php80/usr/share/php:/usr/share/pear:/usr/share/php') in /home/z6kmqmxpi9ug/public_html/wp-settings.php:176 Stack trace: #0 /home/z6kmqmxpi9ug/public_html/wp-config.php(99): require_once() #1 /home/z6kmqmxpi9ug/public_html/wp-load.php(50): require_once('/home/z6kmqmxpi...') #2 /home/z6kmqmxpi9ug/public_html/wp-blog-header.php(13): require_once('/home/z6kmqmxpi...') #3 /home/z6kmqmxpi9ug/public_html/index.php(17): require('/home/z6kmqmxpi...') #4 {main} thrown in /home/z6kmqmxpi9ug/public_html/wp-settings.php on line 176
    There has been a critical error on this website.
    kottanz

    (@kottanz)

    How did you fixed error?

    shonamonteiro

    (@shonamonteiro)

    I have useddivi builder on all my sites and all of them are now showing critical error. Please help

    gemmanltd

    (@gemmanltd)

    hi im getting the same issue update updated to wordpress 6.1

    there’s a critical error on website

    http://www.trufflelovers.co.nz

    please assist me.!!! thank you

    • This reply was modified 3 months ago by gemmanltd.
    Plugin Support lastsplash (a11n)

    (@lastsplash)

    Hi @shonamonteiro @gemmanltd @kottanz

    We look into this if you have reason to believe that the issue is caused by Jetpack.

    If this is the case, please start your own thread, as per the Forum Welcome guidelines?

    https://wordpress.org/support/plugin/jetpack#new-post

    Thank you!

    Plugin Support lastsplash (a11n)

    (@lastsplash)

    Hi @hsclater

    I’m sorry for the trouble you had.

    Has this been resolved after updating Jetpack on the affected sites?

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hey @hsclater,

    It’s been one week since this topic was last updated. I’m going to mark this thread as solved. If you have any further questions or need more help, you’re welcome to open another thread here. Cheers!

    <font _mstmutation=”1″>Efectivamente el error no es de los plugins, el error es de WordPress 6.1.1 como tal. </font>Desde mi punto de vista el problema es con la compatibilidad del php

    <font _mstmutation=”1″></font>

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.