WordPress.org

Forums

WP Email Capture
[resolved] 2 problems with WP Email Capture (7 posts)

  1. jeemer
    Member
    Posted 2 years ago #

    First off, if someone fills in the form and clicks the link in their email they are taken to the correct URL. They can look at the page all they like, it works fine.

    However if they go away from the page, and then click the link again in their email to be taken back there, they can't return. Is there a way around this?

    Secondly in this situation, or if someone tries to sign up for a second time using the same email they are taken to the homepage of my site.

    On the homepage I have a static page with no widgets. Therefore the only warning ("?wp_email_capture_error=Wrong confirmation code" and "?wp_email_capture_error=User already present" respectively) appear in the URL itself. Is there a bit of php I can add to my homepage to allow any error message to appear in the content of the page itself?

    Thanks!

    http://wordpress.org/extend/plugins/wp-email-capture/

  2. leeroymrk
    Member
    Posted 2 years ago #

    How did you fix these? It says "resolved"?

  3. jeemer
    Member
    Posted 2 years ago #

    Yeah I didn't get these issues resolved at all. I didn't set that. Tweeted the creator the same day I posted this, he replied a while later apologising and said he'd look into it, never heard back I'm afraid :/

  4. Rhys Wynne
    Member
    Plugin Author

    Posted 2 years ago #

    Hi All,

    I did resolve this, but my reply got chewed up by a spam bot, so when I posted it, I marked resolved but the reply didn't show.

    Bit busy now, but will aim to reply again. Bit annoyed as it's making me look daft and you're not getting the responses I posted, and nobody seems able to help :(

    Rhys

  5. Rhys Wynne
    Member
    Plugin Author

    Posted 2 years ago #

    Hi All,

    Right the issue is the way in which the plugin works.

    Basically there are two tables, a temp members & a registered members. When a user fills in an email address, it goes into the "temp members" table. When they click on the link they are moved from the temp members into the registered members. As they are moved from temp to registered they are deleted from the temp members table. This is why you are getting the "wrong confirmation code".

    The users already present protects against users registering more than once to a site. This is why when you fill in the form again you get a "user already present".

    A way around this is to add to the confirmation page instructions on bookmarking said page, so they can return to it at a later date.

    Hope that helps.

    Rhys

  6. kmqq
    Member
    Posted 2 years ago #

    Site Crashed after installing plugin - I installed wp-email capture free on site348.com. I entered the pages I wanted the enrolles to be sent to.
    THEN SUDDENLY the screen popped to the General site information page. THEN the site crashed. I am now locked out with this error:

    Parse error: syntax error, unexpected T_STRING in /home/site348/public_html/wp-config.php on line 4

    Please tell me how to fix this and get my site back under my control, please. The site has been down for almost 24 hours. Thanks

  7. kmqq
    Member
    Posted 2 years ago #

    Fixed: Make sure to open wp-config.php in a php editor! It will show immediately which line is the problem. Then upload directly into the php editor the config-sample.php file. If no problem is seen with the highlighted line where is supposed to be, then just type into the sample file the values that you know will work for your database. Save Sample as wp-config. and upload.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Email Capture
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.