Support » Plugin: Auto-tags » 2 issues plz

  • Hello dear,

    Thank you for this great plugin, I love it but I have 2 issues if it could be solved:
    1- generating all posts’ tags doesn’t work properly, it generates tags for 5 or 6 posts only.
    2- Unfortunately it doesn’t support Arabic. What can I do to make it support Arabic.

    Thanks
    Sandy

    http://wordpress.org/extend/plugins/auto-tag/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Same problem here, only the first 5 posts get tagged

    Can’t see that this is limited anywhere in the code, so maybe it’s an api issue?

    only 5 posts also, why?

    Same problem here, doesn’t look like any answer is forthcomming.

    I want to tag more than the last 5 posts in my blog! This is clearly a bug but it seems like the author of the plugin is unwilling or unable to answer it.

    If anyone knows of a similar plugin that will auto tag (I don’t want to have to go and create a list of tags myself) all historical entries in my blog, please let me know!

    Unfortunately I Couldn’t find a solution till now but I’ll tell you ASA I find one…

    I tried many similar plugins…. not good!

    Plugin Author jfoucher

    (@jfoucher)

    Hi, sorry about the delay, version 5.2 solves this issue.

    Plugin Author jfoucher

    (@jfoucher)

    As for arabic support, unfortunately the plugin uses the yahoo api which does not seem support arabic unfortunately…

    Ooooh sad to hear this 🙁

    Thanks for replying.

    Hi, sorry about the delay, version 5.2 solves this issue.

    Do you have any schedule for this update?

    karadayi

    (@karadayi)

    When will you give out the new Update?

    Try this…in auto-tag-setup.class.php replace

    $args = array(
    ‘post_type’ => ‘post’,
    ‘post_status’ => ‘publish’,
    );

    with this

    $args = array(
    ‘post_type’ => ‘post’,
    ‘post_status’ => ‘publish’,
    ‘numberposts’ => -1
    );

    Parameter “‘numberposts’ => -1” allows grabbing all posts available on the site. Hope it helps.

    I found no “auto-tag-setup.class.php” in your Plugin.
    There is only:

      AutoTags.php
      AutoTags.pot
      AutoTagsAjax.php
      readme.txt

    Are you sure you have this plugin http://wordpress.org/plugins/auto-tag/ ?

    Raski… I’ve been having the same issue. The “Retag all posts” under Tools for Auto Tags was only updating the most recent 5-6 posts.

    I found the section of code you referenced, but wanted to know if adding the ‘numberposts’=>-1 should be added to the section above as well? I think one section is for posts and the other is for pages. Right?

    Here is the original code from the plugin:

    $posts= array();
    if ($_POST[‘submit’] == __(‘Retag all posts’, ‘auto-tag’)) {
    $args = array(
    ‘post_type’ => ‘post’,
    ‘post_status’ => ‘publish’,
    );

    $posts = get_posts($args);

    }elseif ($_POST[‘submit’] == __(‘Retag all pages’, ‘auto-tag’)) {
    $args = array(
    ‘post_type’ => ‘page’,
    ‘post_status’ => ‘publish’,
    );

    Hey, Randy.

    Yes, it is the same thing. You can add it in both args and run it.

    Thanks Raski! It seems to have worked. We have a blog with thousands of posts and I don’t think it crawled the entire site, but your modifications definitely resulted in far more successful results! Thanks!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘2 issues plz’ is closed to new replies.