WordPress.org

Support

Support » Plugins and Hacks » [Resolved] 2 ERRORS after updating the plugin

[Resolved] 2 ERRORS after updating the plugin

  • The first error:

    Warning: Invalid argument supplied for foreach() in... /wp-content/plugins/google-document-embedder/functions-admin.php on line 658

    Then, when I deactivated the plugin and activated the Twenty Eleven theme and reactivated the plugin, a new error popped up in addition to the one above:

    Cannot modify header information - headers already sent by (output started at .../wp-content/plugins/google-document-embedder/functions-admin.php:658) in .../wp-includes/pluggable.php on line 876

    (The … is my server path hidden from view)

    Thanks,
    Scott

    http://wordpress.org/extend/plugins/google-document-embedder/

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’m unable to upload images to my new posts with the latest update. I found out 8 copies later that images are actually uploading, but are unable to post from the media uploader. I had to deactivate Google Doc Embedder until this is fixed.

    Upload New Media
    Warning: Invalid argument supplied for foreach() in /wp-content/plugins/google-document-embedder/functions-admin.php on line 658
    23654

    Have never had any problems with the plugin before this update.

    I checked this function code next to the code in the pre-upgrade file and they are identical so this leads me to believe that it’s not the code itself but rather the dependencies on the code, somewhere else, that are creating this error. I’m no authority, for sure – just a graphic designer type. Hopefully the developer will fix this really quickly since this Google embedder is pretty much the standard. I’ve also never had problems with this terrific plugin until now.

    Plugin Author k3davis

    @k3davis

    Those affected by this issue are asked to try the test build here.

    http://tinyurl.com/ccxzwn2 (direct link to download)

    Alternately, you can just remove the gviewer.php and functions.php files from this zip and overwrite your present versions. No deactivation or reinstall should be necessary.

    Please let me know the outcome. Sorry for this inconvenience.

    I tried it both ways and neither worked:
    1. Installed full new .zip you just attached and received same error codes as above
    2. Installed previous version of GDE (pre-update) and just replaced ‘gviewer.php’ and ‘functions.php’ files from new version and received the following errors:
    Warning: require_once(.../wp-content/plugins/google-document-embedder/functions-admin.php) [function.require-once]: failed to open stream: No such file or directory in .../wp-content/plugins/google-document-embedder/functions.php on line 30

    In case I misunderstood your directions, I also tried downloading the current version from this site (main plugin page) and then replaced the ‘gviewer.php’ and ‘functions.php’ files from your new .zip but that also gave the same ‘…on line 658’ error as above.

    Plugin Author k3davis

    @k3davis

    The zip file was updated with an additional fix (same two files). Please retry. Thanks Scott for your help.

    If someone would provide steps to reproduce the problem, that might be helpful. I haven’t seen these errors yet anywhere, so I’m stabbing in the dark a bit.

    The zip file didn’t work for me either.

    Couldn’t install from dashboard:

    Installing Plugin from uploaded file: gde-253.zip

    Unpacking the package…

    Installing the plugin…

    Destination folder already exists. wp-content/plugins/google-document-embedder/

    Plugin install failed.

    cPanel overwrite didn’t work either:

    Setup wasn’t able to create the required tables. Please reactivate GDE or perform a clean installation.

    Deleted the plugin and reinstalled with the zip from dashboard. Appeared to work, but reads Version 2.5.2 instead of the zip name 2.5.3.

    Tried to upload an image into a new post and it just hangs. Trying now to deactivate the plugin, but it’s just spinning and waiting.

    Moved plugin to a tmp folder in cPanel until a good fix is published.

    Plugin Author k3davis

    @k3davis

    Clarification, Cheryl – did you try the newest zip I posted, perhaps while you were writing that response? The version number won’t change as this is a test build.

    You won’t be able to install it completely over the top of your existing plugin except by manually replacing those two files. This download is a complete plugin package, so file replacement or FTP overwrite may be required. I don’t know if cpanel will handle that task appropriately.

    Totally works now 😀
    Ӈ⟑ρℙY ӇøLiↁαϔs!
    (I just sent you a donation on Pledgie)

    Plugin Author k3davis

    @k3davis

    Hi Scott,

    Thanks a lot for helping me fix this issue – and my apologies to those who were affected. The change is included in the released version 2.5.3.

    Thanks for the thoughtful donation also. 🙂 Merry Christmas to you!

    Kevin

    Hi k3davis,

    I replaced the ‘gviewer.php’ and ‘functions.php’ files with the files from this zip http://tinyurl.com/ccxzwn2 and still having the errors when downloading new images to wp.
    error

    Warning: Invalid argument supplied for foreach() in ../wp-content/plugins/google-document-embedder/functions-admin.php on line 658

    Warning: Invalid argument supplied for foreach() in ../wp-content/plugins/google-document-embedder/functions-admin.php on line 658

    thanks

    got it fixed after updating the plugin from the admin interface, many thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] 2 ERRORS after updating the plugin’ is closed to new replies.