WordPress.org

Forums

WordPress MU Domain Mapping
2 Domains, 1 hosting, WPMU - Missed steps? (5 posts)

  1. Eleven34 Studios
    Member
    Posted 11 months ago #

    I have a client whose site I built previously using wordpress. They recently bought another domain name for another business they're starting. So, I wanted to have both of their domains hosted on their hosting (they have godaddy Deluxe). I setup WPMU on it and would love to have both sites listed on their as well. Thus I came across your plugin which is what I THINK I need to make that happen. I set it up on the back of godaddy that the domain would be hosted on their current hosting setup (On the hosting page I added the domain to it so both domains are listed on the hosting domains page). I'm not sure if there's more that I need to do on the backend there... both A (Host) listings have the same I.P. address (which is not a static ip, but I think Godaddy will update it since I have it added to the hosting?). The first site is in the root folder and the secondary site is listed in a subfolder. When I go to the secondary page url in a browser it pulls up godaddy's parked page so I believe that means the hosting is working correctly.

    Also, when I go to network setup, I get this error on the top of the page:
    Warning: strpos() [function.strpos]: Empty delimiter in D:\Hosting\11794816\html\wp-admin\network.php on line 327

    All this to say, when I follow the steps and get to the point of adding the domains to the mapping, they don't show up and aren't added. I added the second domain on wpmu network admin and it's showing in the site listing but it's not accessible. First time running through this, obviously, any help on this would be greatly appreciated. Thank you!

    https://wordpress.org/plugins/wordpress-mu-domain-mapping/

  2. Eleven34 Studios
    Member
    Posted 11 months ago #

    I figured out the issue with not seeing the new site, added myself as a user to it and it now shows up -.- Noob

    Now when I try to pull up the dashboard it's not there. Joy
    Also, when I try to use anything on the page "Domains" under settings, it doesn't work. When I enter in a domain in the search and try to search, nothing changes or shows up. Then if I add a site name/domain and select primary and hit add, nothing changes there either.

  3. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    When I go to the secondary page url in a browser it pulls up godaddy's parked page so I believe that means the hosting is working correctly.

    That sounds like your hosting is not set up correctly.

  4. Eleven34 Studios
    Member
    Posted 11 months ago #

    Well, I might have used the wrong terminology. When I told the hosting to add a domain, it created a sub folder on the hosting. The subfolder contained a welcome.html page which is what is being pulled up when the page is installed. I started uploading wp to the subfolder and now it loads the wp stuff just fine.

  5. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    started uploading wp to the subfolder and now it loads the wp stuff just fine.

    Using domain mapping doesn't involve installing another copy of WP.

Reply

You must log in to post.

About this Plugin

  • WordPress MU Domain Mapping
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic