WordPress.org

Forums

2-Column missing on post.php Screen Options (5 posts)

  1. robertcedwards
    Member
    Posted 4 years ago #

    Our screen option dropdown menu is missing in the screen options area of Post.php

    I've reset the plugins folder by renaming it and creating a new plugins folder that is empty.
    I've reinstalled the wp-admin folder
    I've increased the available memory
    With an admin logged in the only available option is one column, if I open firebug and inspect the Radio Button there is only one label being rendered, "1 Column", but if I change the value to "2" and click on the element, a blank box appears where Publish, etc. are normally.
    This seems to point to the php not rendering out that element?

    Another issue happening in post.php is when a non-admin user is logged the Publish box is missing completely, if you open the screen options menu and click on "1" Column radio (the only option there as per problem above) the publish box appears!

    Help help help!

    Thanks

  2. nancygolliday
    Member
    Posted 4 years ago #

    That's happening on one of my client's sites too. Not anybody else's though! Weird!!! Can't wait to get the fix before he has to start posting...this will drive him nuts!

  3. twstrldy
    Member
    Posted 3 years ago #

    I had the same trouble with a client I was working for. I searched for about an hour and found a forum post that is from over a year ago about the fix.

    mrmist wrote

    If you switched to 1 column view in screen options then the "missing" boxes are meant to move to the bottom of the window, you'd have to switch back to 2 column and then manually move the boxes back to the top right.

    source: `http://wordpress.org/support/topic/entire-column-missing-from-admin-edit-page
    I wondered what those arrows meant! Those are moveable modules. Place them where you need to so you can do your editing.

    Thank you mrmist.

    Good luck in your editing work.

  4. nancygolliday
    Member
    Posted 3 years ago #

    Thanks so much for that insight!!! We were just creating a new user to bring up the 2 column view and "not" touching the single column anymore! But I've passed this on to a client who didn't do that and she will just love you for this - and me too - thanks again!!!

  5. twstrldy
    Member
    Posted 3 years ago #

    Your very welcome. I also noticed another little tool that eliminates the need to switch columns during editing. To the right of the spellchecker button on the "visual tab" is a full screen button which allows for exit full screen mode after editing if you want to make any checks to the plugins so they don't repost but just update the previous post when you click the update button. Or if this isn't a concern there is a convenient update button available in the full screen mode that hides while editing until you mouse over the top portion for it to reappear.

Topic Closed

This topic has been closed to new replies.

About this Topic