WordPress.org

Forums

NextCellent Gallery - NextGEN Legacy
2 bugs which have carried over from NextGen (6 posts)

  1. pjamedia
    Member
    Posted 1 year ago #

    Bug 1: Images containing space in filename causes broken thumbnails in gallery admin, plus unable to view these images in admin, but on page in site the images display fine.
    Detail 1: I noticed that for several imported galleries I have (imported using the Import folder option), inside the admin area for the gallery, the image thumbnails show broken images. Doing some searching, noticed that this is only the case where the underlying images contain spaces in their file names.
    Expected Functionality 1: I would expect that the thumbnails be siaplayed properly in the admin area and images be viewable, even if the underlying image files contain spaces in the file name

    Bug 2:When creating Albums, unable to choose the desired Preview Image for the album as only small selection of images are displayed in Preview Image drop-down
    Detail 2:If you create an album containing multiple galleries, then under Albums, select an your album of choice from the drop-down on the page, then when loaded click Edit, a popup appears where you can edit the Album Name, Preview image etc. Clicking the Preview image drop-down, only a few items are displayed in the list, and in my case, none of the displayed images are ones contained in the selected album - but from 3 completely unrelated galleries.
    Expected functionality 2: I would expect that when opening the Preview Image drop-down to be presented with a list of all images contained in all galleries nested within the selected Album only.

    I am using WP 3.9, NextCellent Gallery v1.9.17

    Thanks, Paul A

    https://wordpress.org/plugins/nextcellent-gallery-nextgen-legacy/

  2. WPReady
    Member
    Plugin Author

    Posted 1 year ago #

    Hi pjamedia,
    thanks for your comments.

    Great findings. We'll address these bugs on next release.
    Best regards

  3. pjamedia
    Member
    Posted 1 year ago #

    No worries.
    I just updated to 1.9.18. I see the issues mentioned above haven't yet been addressed. I look forward to this happening so I can release my new WP site.

    Thanks for your efforts, Paul A

  4. pjamedia
    Member
    Posted 1 year ago #

    Just updated to 1.9.19 - release notes say that bug for files/folders with spaces have been resolved. Just checked and the bug I reported above (in fact both of them) still remain. If I now try to recreate the thumbs in a gallery, it errors.

    I'd be gladly be willing to test any release code for the developer if this would help fix my issues. As I say, both issues detailed in the OP are still present in 1.9.19

  5. niknetniko
    Member
    Posted 1 year ago #

    The first issue is indeed resolved: if you import new images, they are all sanitized (remove spaces and such).

    However, for existing images, you have to go to the gallery and press Scan folder for new images.

  6. pjamedia
    Member
    Posted 1 year ago #

    You are indeed correct. Many thanks for fixing issue 1. Now for Issue 2! Until this is resolved I am unable to deploy my new WP website, as I can't have the Albums displaying the wrong master image.

    Thanks again for sorting the first issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic