Yoast SEO
2 Bugs related to Google Authorship settings (1 post)

  1. JC John Sese Cuneta
    Posted 3 years ago #

    WordPress version: 3.5.1 Multisite subdirectory
    WordPress SEO version: 1.4.4

    I did this:
    Part 1:
    1) Added a "Google +" link under my profile.
    2) Enabled Titles & Metas > Home > Author highlighting: > my username

    Part 2:
    1) Entered link to Titles & Metas > Home > Google Publisher Page:

    Part 3:
    1) Deleted all Google Authorship setting in the Titles & Metas > Home section (ie Author highlighting set to "Don't show" and Google Publisher Page left empty)
    2) Left the "Google +" link under my profile intact

    Part 4:
    1) Deleted the "Google +" link under my profile

    I expected the plugin to do this:
    Part 1: It showed up correctly.
    Part 2: Add a new meta rel="publisher" line
    Part 3: Not show any meta rel="author" / meta rel="publisher" lines
    Part 4: Correct

    Instead it did this:
    Part 1: It showed up correctly.
    Part 2: But the plugin instead replaced the meta rel="author" line with the meta rel="publisher" line
    Part 3: But the plugin is still showing meta rel="author" line
    Part 4: Correct

    * Additional comments:
    For Part 3 and 4, it appears that as long as the "Google +" field under Profile is filled up, the meta rel="author" line shows up in the homepage (I haven't tested if it shows up in posts and pages), regardless if the setting "Author highlighting" is set to "Don't show".

    For Part 2: I'm not sure if there are negative effects on having meta rel="author" and meta rel="publisher" together, but from my other sites, it works fine and Google recognizes it as well, as well as in RDFa. Works well in searches too.

    That's all, thank you very much.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

  • RSS feed for this topic
  • Started 3 years ago by JC John Sese Cuneta
  • This topic is not resolved
  • WordPress version: 3.5.1