WordPress.org

Support

Support » How-To and Troubleshooting » 2 Blog Post Issues

2 Blog Post Issues

  • tastyjams
    Member

    @tastyjams

    Hello WordPress forum!

    I know a lot of problems about blog posts spring up here but I couldn’t find a solution to my specific problem. The site I am working with is sharmanevents.com

    I need the Blog page on my client’s website to show posts that are added to the Blog category. The problem I’m having is that new posts are defaulting to the wrong url, right now when I create a post, regardless of what category I set it to, the permalink created goes to sharmanevents.com/services instead and doesn’t give any option to redirect it.

    Basically I’m having trouble getting the Blog page to just show posts placed in the Blog category. Help would be deeply appreciated!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Check Settings > reading and see if you have set services page for posts. If so reset blog as your posts page.

    tastyjams
    Member

    @tastyjams

    Hey Krishna,

    Thanks for your reply – the problem with this fix is that my homepage needs to be set as ‘Your latest post’ in order for the theme I have to display the correct front page. If I set it to a static page it will affect the homepage and not the blog page I want.

    Any other ideas? Thanks!

    tastyjams
    Member

    @tastyjams

    A quick update, I did figure out my url structure was being set in the settings > permalink settings – so I was able to fix that.

    I am still working on the blog posts issue, help would be greatly appreciated!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘2 Blog Post Issues’ is closed to new replies.