Support » Plugin: Page Builder by SiteOrigin » 2.9.6 seems to disable Gutenberg editor

  • Resolved lauramay7

    (@lauramay7)


    Hi guys,
    2.9.6 seems to totally disable the Gutenberg editor. We’ve rolled our sites back to 2.9.5 for the meantime. Just wanted to let you know!
    Thanks,
    Laura

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Andrew Misplon

    (@misplon)

    Hi Larua

    Thanks for posting.

    In 2.9.6, if you head over to Pages > All Pages and click the drop-down arrow next to Add New, you can add a new Block Editor page.

    We’ve been rapidly shipping updates the past few weeks, I’ll get our documentation updated and expanded ASAP. The SiteOrigin Layout and SiteOrigin Widget blocks are ready to go for your Block Editor pages.

    If you aren’t using Page Builder for a post type like say Posts, you can disable Page Builder from Settings > Page Builder > General: Post Types.

    As questions arise, please let us know, we’d be happy to help.

    @misplon

    Having same behavior : 2.9.6 seems to totally disable the Gutenberg editor.

    All existing pages (that were not using Page Builder) are now editable only with the classical editor.

    I could create new pages with “the drop-down arrow next to Add New” but what do I do to edit my old pages in Gutenberg ?

    @misplon

    Just had a look at your modification page:
    2.9.6 – 10 December 2018
    Default to Page Builder interface for post types set to use Page Builder in Settings.

    Could you make this only for new pages ?

    Plugin Author Andrew Misplon

    (@misplon)

    Hi @ldeschenes

    Thanks for posting. We’re looking into the existing page, non-Page Builder page issue now. I’ll update you ASAP.

    Good Afternoon, In favor of not creating a separate topic since my problem is quite similar, I am writing here.

    The main problem is with the fact that by creating a post on page from a place other (eg. the toolbar ) than the corresponsive admin section, the default editor will always result to classic, with no option to do otherwise.

    I understand that with the current state of gutenberg, pagebuilder couldn’t be used exactly as is, so this choice seems somewhat reasonable.

    This is isn’t much of a problem for me since i can just get used to it and use the admin section for page creation. But i have clients sites in which, i want to leverage the ability to use reusable blocks combined with your layout block, a combination which is suprisingly quite powerfull actually.

    Most of them have learned to use the toolbar for creating posts and as you can imagine this would cause some frustration.

    It seems reasonable at least for me that this “by default classic” shall be an option that can be opt out on the settings, or at least have the same option for creating a post/page with gutenberg on the toolbar as well.

    Im also quite happy that the issue @lauramay7 has raised is actually known and being
    looking into, since i ran into it as well!

    Plugin Author Andrew Misplon

    (@misplon)

    Hi @jimmyst1

    Thanks for your considered feedback. I’m working with the team this evening. I’ll update you and the topic overall as soon as I can. Thanks again.

    Hi
    I’m writing just to confirm that I am experiencing the same problem as @lauramay7 , @ldeschenes and @jimmist1, and so that I can get updates on this thread.

    Btw I think it’s right to underline that Page Builder is not disrupting anything: the sites are working perfectly, only the editor is blocked in classic mode.

    Thanks for your kind and prompt support

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks for posting, we’ll resolve the existing posts/pages not in Page Builder in the next update and introduce a setting at Settings > Page Builder to change new post/page behavior to solve the challenge outlined by @jimmyst1.

    Plugin Author Andrew Misplon

    (@misplon)

    Hi everyone, Page Builder 2.9.7 has been released. @ldeschenes, the issue with existing pages that weren’t using Page Builder should now be resolved, sorry about that bug. @jimmyst1, please head over to Settings > Page Builder where you can deactivate new pages defaulting to Classic, that’ll resolve the ‘pages added from toolbar’ challenge. @lauramay7 and @elenaocone, please also head over to Settings > Page Builder to deactivate the default to Classic option. A once off notification will be presented when creating a new page to highlight the new setting. Thanks all for your patient feedback, it’s most appreciated. We’re here for questions and requests.

    Andrew,

    Thanks for resolving the issues.
    I confirm that the issue with existing pages that weren’t using Page Builder is resolved.

    🙂

    • This reply was modified 1 year, 2 months ago by ldeschenes.
    • This reply was modified 1 year, 2 months ago by ldeschenes.
    Plugin Author Andrew Misplon

    (@misplon)

    Super, thanks for testing and confirming. As questions arise in the future, please let us know. All the best.

    Using WP v 5.0.2 / Page Builder Version 2.9.7 – I can export the json layout but opening a new page using Block Editor isn’t working. I followed your instructions:
    “Pages > All Pages and click the drop-down arrow next to Add New, you can add a new Block Editor page.”

    I get the option of Block Editor but the new page opens in the classic editor with no options to change it to Block Editor.

    I tried this in WP multisite first and then thought it might be an issue with multisite. I tried again locally using MAMP and still the same issue.

    UPDATE – so if I disable the Classic Editor plugin this works. Slightly worried about Gutenberg overwriting my pages but I’ll see how it goes.

    • This reply was modified 1 year, 2 months ago by asaracena.
    Plugin Author Andrew Misplon

    (@misplon)

    Hi @asaracena

    Thanks for hanging in there with us through this transition period. Unfortunately, Pages > All Pages > Add New: Block Editor can’t override the Classic Editor plugin. Glad to hear you’ve made progress. If any further questions arise, please let us know 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘2.9.6 seems to disable Gutenberg editor’ is closed to new replies.