Support » Plugin: Elementor Website Builder » 2.7 Bad Update

  • Resolved mgsolidus

    (@mgsolidus)


    Hi,

    2.7 broke image carousels for me. I’ve had to downgrade for now.
    Image: https://gfxf.net/images/2019/09/10/carousel.png

    Console error:

    frontend.min.js:2 Uncaught TypeError: this.elements.$carousel.slick is not a function
    at r.onInit (frontend.min.js:2)
    at r.<computed> [as onInit] (frontend-modules.min.js:2)
    at r.trigger (frontend-modules.min.js:2)
    at r.<computed> [as trigger] (frontend-modules.min.js:2)
    at r.u (frontend-modules.min.js:2)
    at r (frontend-modules.min.js:2)
    at r [as constructor] (frontend-modules.min.js:2)
    at new r (frontend-modules.min.js:2)
    at e.exports.addHandler (frontend.min.js:2)
    at e.exports (frontend.min.js:2)

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,

    A patch version (2.7.1) came out that should take care of this issue.
    Could you upgrade Elementor to 2.7.1 and let us know if the problem persists?

    • This reply was modified 2 years, 1 month ago by udidol.
    Thread Starter mgsolidus

    (@mgsolidus)

    Hi,

    That update does not fix the issue, neither does 2.7.2.
    Reverting back to 2.6.8 again.

    Did you try to empty your website and browser cache?

    Thread Starter mgsolidus

    (@mgsolidus)

    Yes, just tried again.
    Updated to 2.7.2, all caches cleared. Carousel is still missed up and still this error is in console,

    frontend.min.js:2 Uncaught TypeError: this.elements.$carousel.slick is not a function
    at r.onInit (frontend.min.js:2)
    at r.<computed> [as onInit] (frontend-modules.min.js:2)
    at r.trigger (frontend-modules.min.js:2)
    at r.<computed> [as trigger] (frontend-modules.min.js:2)
    at r.u (frontend-modules.min.js:2)
    at r (frontend-modules.min.js:2)
    at r [as constructor] (frontend-modules.min.js:2)
    at new r (frontend-modules.min.js:2)
    at e.exports.addHandler (frontend.min.js:2)
    at e.exports (frontend.min.js:2)

    Thread Starter mgsolidus

    (@mgsolidus)

    I finally got the update working, but now 1 issue remains.
    Carousel arrows are showing on desktop where before they weren’t.

    Image: https://gfxf.net/images/2019/09/18/1.png

    There are 4 images in this carousel, arrows should not be there.

    Hi,

    You can set your carousel so arrows are not displayed, in the Image Carousel settings, under Content > Image Carousel > Navigation.

    Thread Starter mgsolidus

    (@mgsolidus)

    Hi,

    I know of that setting but that one can’t be controlled on a device-specific basis.
    I want arrows to appear on mobile devices so people know they can scroll, but I don’t want arrow on desktop.

    udidol

    (@udidol)

    You can use CSS to hide the arrows using media queries.
    The CSS to put in the media queries where you want to hide the arrows:

    .swiper-button-next, .swiper-button-prev {
       display: none;
    }
    Thread Starter mgsolidus

    (@mgsolidus)

    Hi,

    That specific code didn’t work for me, but I got it working with this:

    @media (min-width: 790px) { 
       .elementor-swiper-button {
       display: none;
    }
    }

    Problem solved.

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘2.7 Bad Update’ is closed to new replies.