Support » Plugin: Fast Velocity Minify » 2.5.7 doing something strange with Js merging

  • Resolved Paulka

    (@paulka)


    I should have tested it on my staging site first….

    So after the upgrade the way it merges js files seems to have changed so drastically that somewhere along the process a overflow:hidden gets added to my body style. I cannot understand where it’s coming from, all I know is if I “Disable JavaScript processing” it works correctly again.

    Any help would be greatly appreciated. Decombing the JS files has added several seconds to my load time.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • same story here

    Plugin Author Raul P.

    (@alignak)

    Hi there,

    There’s definitely not any overflow:hidden being added by FVM.
    It’s simply merging and pushing whatever you already have there.

    There wasn’t any change on how the plugin merges the JS code, only on how CSS is merged. And you can try to test if the CSS merging option is causing trouble, if you choose to inline all css instead.

    If you are having trouble with JS merging, I would very much like to look into it.

    Is there any error on the google console log?
    Can you post a screenshot of your settings page?

    Meanwhile, you can revert to the previous version, if you download it here:
    https://downloads.wordpress.org/plugin/fast-velocity-minify.2.5.6.zip

    Does the version 2.5.6 work fine?
    If not, was there any other plugin or theme update?

    If you have a staging for testing, kindly send me access via contact form on fastvelocity.com and I’ll take a closer look.

    Thanks

    Hi Raul,

    Thanks so much for your FASTVELOCITY reply!

    So Here’s what I found so far:

    1. It’s not an FVM plugin issue, the issue appears to be related to the MailChimp for Woocommerce plugin. Disabling that plugin also fixes the issue.

    2. I have attempted to exclude their JS using the exclude box: */wp-content/plugins/mailchimp-for-woocommerce/public/js/mailchimp-woocommerce-public.min.js
    But it didn’t make a difference. (@4hunter for confirmation do you also use this plugin?)

    3. To confirm it’s not directly related to the FVM update I downgraded to 2.5.6 and it was still happening.

    It was really just poor site management on my part to upgrade 3 plugins without testing properly.

    I’d really like to learn, could you point me in the right direction to use the google console log? I was using the chrome dev tools, but I’m not sure how to use the console, and on looking there aren’t any errors.

    I really appreciate your assistance!

    Plugin Author Raul P.

    (@alignak)

    I see you added most, if not all js files to the ignore list… but that’s not the way to fix it, even if it seems as it works.

    Also sorry, I was talking about the dev tools, console log (google chrome).
    http://prntscr.com/mh7aij

    Although this may not be related, I saw an error:
    Uncaught SyntaxError: missing ) after argument list

    Looking forward, that error comes from a script loading from acp-magento.appspot.com which seems like, they use an attribute with double quotes instead of the default wordpress way of using single quotes.
    http://prntscr.com/mh7llp

    This made me realize that some plugin authors may be doing it wrong, so I pushed an update to 2.5.8 to bypass this kind of situation, and that error should go away when the defer for pagespeed option is enabled.

    Other than that, I am not sure how I can help you further, without looking at your site from wp-admin and doing some tests. If you have a staging for testing, let me know.

    That mailchimp plugin, may have a css file too.
    Try to add only /mailchimp-for-woocommerce/public/ to the ignore list.

    Hi Raul,

    You’re right, I selected the option to “Disable JavaScript processing” just while I find another solution on my live site.

    Thank you for your offer. The error is present on the staging site, so I did send through my staging site admin details on your contact page on the fastvelocity website yesterday. Shall I resend?

    I have tested 2.5.8 and it still occurs, adding */mailchimp-for-woocommerce/public/* to the ignore list, did not help.

    G

    (@gnetworkau)

    @paulka it doesn’t need asterisks.
    just use:
    /mailchimp-for-woocommerce/public/

    Plugin Author Raul P.

    (@alignak)

    I sent you an email already with the explanation, so I’ll be closing this.

    It’s basically server and cache related.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘2.5.7 doing something strange with Js merging’ is closed to new replies.