Support » Plugin: Elementor Page Builder » 2.5.2 is also broken

  • Resolved a1exus

    (@a1exus)


    I updated elementor plugin from 2.5.0 to 2.5.1 and then to 2.5.2, wordpress’ rendering white screen of death…

    php error log:

    [Tue Mar 05 13:14:40.211613 2019] [:error] [pid 15834] [client X.X.X.X:49408] PHP Warning: ucwords() expects exactly 1 parameter, 2 given in /var/www/html/X/wp-content/plugins/elementor/includes/autoloader.php on line 159, referer: https://X/wp-admin/admin.php?page=elementor

Viewing 9 replies - 1 through 9 (of 9 total)
  • [Tue Mar 05 14:39:44.289534 2019] [:error] [pid 17450] [client X.X.X.X:51310] PHP Fatal error: Class ‘Elementor\\Control_Base_Multiple’ not found in /var/www/html/X/wp-content/plugins/elementor/includes/controls/base-units.php on line 16, referer: https://X/wp-admin/admin.php?page=elementor

    • This reply was modified 2 months, 2 weeks ago by  .
    Plugin Author Yakir Sitbon

    (@kingyes)

    Can you paste here your System Info? (WP Dashboard -> Elementor -> System Info)

    Plugin Author Yakir Sitbon

    (@kingyes)

    BTW, Please deactivate all your plugins and change to Default WP Theme. and let me know if the problem gone.

    
    == Server Environment ==
    	Operating System: Linux
    	Software: Apache/2.4.6 (Red Hat Enterprise Linux) OpenSSL/1.0.2k-fips PHP/5.4.16
    	MySQL version: MariaDB Server v5.5.59-MariaDB-38.11
    	PHP Version: 5.4.16
    	PHP Max Input Vars: 1000
    	PHP Max Post Size: 32M
    	GD Installed: Yes
    	ZIP Installed: Yes
    	Write Permissions: All right
    	Elementor Library: Connected
    
    == WordPress Environment ==
    	Version: 5.1
    	Site URL: https://X.X.X
    	Home URL: https://X.X.X
    	WP Multisite: No
    	Max Upload Size: 32 MB
    	Memory limit: 40M
    	Permalink Structure: /%postname%/
    	Language: en-US
    	Timezone: 0
    	Admin Email: X
    	Debug Mode: Inactive
    
    == Theme ==
    	Name: Zakra Child
    	Version: 1.1.2.1551365788
    	Author: ThemeGrill
    	Child Theme: Yes
    	Parent Theme Name: Zakra
    	Parent Theme Version: 1.1.3
    	Parent Theme Author: ThemeGrill
    
    == User ==
    	Role: administrator
    	WP Profile lang: en_US
    	User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
    
    == Active Plugins ==
    	Classic Editor
    		Version: 1.4
    		Author: WordPress Contributors
    
    	Contact Form 7
    		Version: 5.1.1
    		Author: Takayuki Miyoshi
    
    	Duplicate Page
    		Version: 3.2
    		Author: mndpsingh287
    
    	Elementor
    		Version: 2.4.7
    		Author: Elementor.com
    
    	RARA One Click Demo Import
    		Version: 1.2.6
    		Author: raratheme
    
    	Theme Editor
    		Version: 1.9
    		Author: mndpsingh287
    
    	ThemeGrill Demo Importer
    		Version: 1.5.6
    		Author: ThemeGrill
    
    	Ultimate Responsive Image Slider
    		Version: 3.3.1
    		Author: WP Frank
    
    	Wordfence Security
    		Version: 7.2.3
    		Author: Wordfence
    
    == Log ==
    	: <table><thead><th>JS: showing 2 of 2</th></thead><tbody class="elementor-log-entries"><tr><td>JS: 2019-02-25 23:09:30 [error X 3][https://X.X.X/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.7:2:167472] <strong>Cannot read property \'errors\' of undefined</strong> </td></tr><tr><td>JS: 2019-02-26 17:42:08 [error X 3][https://X.X.X/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.7:2:78085] <strong>Object doesn\'t support property or method \'contains\'</strong> </td></tr></tbody></table><table><thead><th>PHP: showing 3 of 3</th></thead><tbody class="elementor-log-entries"><tr><td>PHP: 2019-03-05 14:00:18 [error X 116][/var/www/html/X.X.X/wp-content/plugins/elementor/includes/controls/base-units.php::16] <strong>Class 'Elementor\Control_Base_Multiple' not found</strong> [array (
      'trace' => '
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ',
    )]</td></tr><tr><td>PHP: 2019-03-05 17:14:10 [warning X 46][/var/www/html/X.X.X/wp-content/plugins/elementor/includes/autoloader.php::159] <strong>ucwords() expects exactly 1 parameter, 2 given</strong> [array (
      'trace' => '
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ',
    )]</td></tr><tr><td>PHP: 2019-03-05 17:39:37 [notice X 2][/var/www/html/X.X.X/wp-content/plugins/elementor/core/logger/items/base.php::101] <strong>Array to string conversion</strong> [array (
      'trace' => '
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ',
    )]</td></tr></tbody></table><table><thead><th>Log: showing 2 of 2</th></thead><tbody class="elementor-log-entries"><tr><td>2019-03-05 15:38:35 [info] <strong>Elementor data updater process has been completed.</strong> [array (
      'plugin' => 'Elementor',
      'from' => '2.4.7',
      'to' => '2.5.1',
    )]</td></tr><tr><td>2019-03-05 17:00:25 [info] <strong>Elementor data updater process has been completed.</strong> [array (
      'plugin' => 'Elementor',
      'from' => '2.5.1',
      'to' => '2.5.2',
    )]</td></tr></tbody></table>

    After I downgraded plugin back to 2.4.7, site is back online…

    2.5.2 is broken for me too.
    I can also confirm that downgrading to 2.4.7 fixes the problem.

    UPDATE
    I have discovered that the problem, in my case was caused by the Black Studio TinyMCE Widget plugin. Disabling the plugin has resolved the issue for me.

    Same issue here. Downgrading fixed it but this caused us some major problems.

    Memory limit: 40M -> 256M it’s better!!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.