Support » Plugin: PublishPress Future: Automatically Unpublish WordPress Posts » 2.4.2 Update caused Year not to behave

  • Resolved bellinghamfitz

    (@bellinghamfitz)


    We have updated to Version: 2.4.2, and since then we cannot expire posts using a set default of “+12 months”. Before, Post Expirator would show the expiration date as 12 months in the future…now, it only shows the CURRENT year.

    Our expiration is set to +12 months. Now the default expiration date is today’s date instead of a year from now.

    Worked fine until the update…I’ve disabled the plug-in on my site until we can get this resolved. THANKS!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Steve Burge

    (@stevejburge)

    @bellinghamfitz thanks for reporting this. Does it work if you roll back to 2.4.1 with a plugin like this?

    https://wordpress.org/plugins/wp-rollback/

    Thread Starter bellinghamfitz

    (@bellinghamfitz)

    Hi Steve, and thanks for the quick reply!

    Rollback to 2.4.1 did not do the trick (hence my forum post!)…but indeed I had not tried rolling further back, and rolling back to 2.4.0 did put things back to expected behavior.

    I’ve turned off auto-updates…

    Thanks again…is this something that is known or, would you like any troubleshooting help?

    Plugin Author Steve Burge

    (@stevejburge)

    Hi @bellinghamfitz. This looks like a bug has been around a while. 2.4.0 came out last year.

    We can see confirm on our side, but any feedback you have on how it’s acting (screenshots in particular), would be helpful.

    Thread Starter bellinghamfitz

    (@bellinghamfitz)

    It’s possible we didn’t update until 2.4.2…setting to “auto-update” plugins is relatively new on our end.

    Uh, I will reinstall 2.4.2 and try to reproduce, and generate some screenshots…but it’ll have to be after hours! Check in in a couple days! 🙂

    Thanks again!

    Plugin Author Steve Burge

    (@stevejburge)

    Awesome thanks @bellinghamfitz

    No worries, we won’t be digging into this bug until Monday

    Plugin Author Steve Burge

    (@stevejburge)

    Can you test this pre-release version, please?
    https://app.box.com/s/9z2hinz159tk8kt4xt5nsty02aojliwx

    It has support for using quotes, but the ideal approach is to enter the default date without them

    Thread Starter bellinghamfitz

    (@bellinghamfitz)

    Ah, yes! I’d be happy to. Will do it late today and report back with result!

    THANKS!!!!

    Thread Starter bellinghamfitz

    (@bellinghamfitz)

    THANK YOU KIND SIR! The beta plugin does indeed work properly. Setting the default expiration time to +12 Months behaves as expected and posts are expiring properly.

    I very much appreciate your help on this! Problem solved!

    G

    Plugin Author Steve Burge

    (@stevejburge)

    Great, thanks @bellinghamfitz

    We’ll plan to officially release this next week.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘2.4.2 Update caused Year not to behave’ is closed to new replies.