Support » Plugin: 404page - your smart custom 404 error page » 2.2 with Polylang

  • Resolved Franck Frémont

    (@franck-fremont)


    Hello,

    I still have a 404 error appearing with the 2.2 version.
    It was already the case with Polylang with the 2.1 version.
    It appears only for my customers’ websites using Polylang.
    For these sites, the 1.4 version works perfectly well.

    I know you do your best, and I would like to thank you even if the 2.2 version does not solve this little problem.

    Best,

    Franck

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Peter Raschendorfer

    (@petersplugins)

    Hi Franck,

    is it the problem with the Divi theme you’re talking about?

    The guys at Elegant Themes kindly supported me with a testing license. The problem should be solved in upcoming version 2.3. I’ve tested it with Divi 3.0.18 and Polylang 2.0.7 on WP 4.6.1 and it seems to work fine.

    Would you please test the current dev version? You can download it from https://downloads.wordpress.org/plugin/404page.zip.

    Peter

    Hi Peter,

    On the websites where the theme and the two plugins are activated, my working (and tested) configuration is today WordPress (4.6.1), Divi (2.0.17), Polylang (2.0.7) and 404page (1.4).

    So it’s nearly exactly the same configuration you use to work for your version 2.3.

    I already tried 404Page 2.2. Not with all the latest versions of Divi of course, but with some of them and these tests did not work. The 2.2 version is activated without any problem on other sites without Polylang, with all the other components at the same level than the working configuration described above. I tried Divi 2.0.18 and I found another problem (builder not working on some pages) but it has probably nothing to do with Polylang and/or 404Page.

    In any case, I am ready to test your 2.3 version when you like it. 🙂

    Best,

    Franck

    • This reply was modified 7 months, 2 weeks ago by .
    • This reply was modified 7 months, 2 weeks ago by .
    • This reply was modified 7 months, 2 weeks ago by .
    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Hi Franck,

    thanks for details. The link I’ve posted allows you to download a beta version of the upcoming 2.3. This one should fix the problem. Please test this. Thanks.

    Peter

    Hi Peter,
    I just tried the 2.3 version.
    Sorry to have waited until the weekend but I had quite a busy week.
    I still have the same issue.
    The destination page doesn’t keep the parameters chosen in Divi (full width).
    It appears after the move to 2.3 with the side column.
    And this not the right design for the Homepage.
    And that appears only with the configuration Divi + Polylang + 404page.
    Without Polylang, other sites with 404 page 2.2 display their home page (when created in full width) in full width.
    I hope it helps.
    In any case, I appreciate your efforts. 🙂
    Best,
    Franck

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Hi Franck,

    sorry but I’m not able to reproduce this problem.

    On my test site it works without any problems. I can choose between “Left Sidebar”, “Right Sidebar” and “Full Width”. All settings work fine. Also I’ve tried to create different pages for different languages and tested those settings there. It works.

    Could yo please try to deactivate all other plugins except Polylang and 404page. I’m pretty sure it works then because this is how I’ve tested it. Reactivate the plugins one by one and test each step.

    Peter

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Any news?

    Franck Frémont

    (@franck-fremont)

    Hi Peter,

    No, no news. 🙂
    Still using the 1.4 version inside the websites with Polylang included.
    As long as there is no vulnerability detected in the 1.4 version, it’s not a problem.
    When I have time enough, I will probably create a hand-made 404 page for the Polylang websites.

    Have a great day and thanks for the follow-up! 🙂

    Franck

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Hi Franck,

    I’d really love to solve this issue. Maybe this could also help others. Must be a problem with another plugin you’re using, because it works on my test site.

    Would it be possible for you to send me a list of all your active plugins? Maybe I can figure it out.

    Peter

    Hi Peter,

    Could you let me your email on https://www.webzenitude.com/contact/ ?

    I will then send you the list of all the plugins of one of the concerned websites.

    Best,

    Franck

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Hi Franck,

    thanks for sending me the screenshots. You’ve a lot of plugins active… Unfortunately I’m not able to test all of them because some of the plugins you’re using are premium plugins. But I’ve installed all free plugins and activated them together with the Divi theme. Except for the premium plugins this should be the same setup as yours.

    Well … how shall I put it? Everything works fine on my testing machine. I can use different Divi settings for the 404 page in different languages and I can use the Divi Builder to create a 404 page. Everything works as it should be.

    I took a look at the premium plugins I’m not able to test and it’s hard to imagine one of them causes the issue. Must be some kind of configuration I’m not able to reproduce.

    So I analyzed the changes from version 1.4 to 2.0 and tried to guess which one maybe causes your problem. After fiddling around a while I found a different solution to load the translated page with Polylang. This solution now also works in Standard Mode so it’s no longer necessary to automatically switch to Compatibility Mode if Polylang is detected.

    Would you please download and install the current development version from https://downloads.wordpress.org/plugin/404page.zip and test it. In this version you should be able to switch to Standard Mode which approximately corresponds to how version 1.4 worked.

    I’m curious about your testing results.

    Regards,
    Peter

    Hi Peter,

    I use now this last dev version as a production version for the sites using both Divi and Polylang (I know it’s bad! LOL)

    It works perfectly.

    Thanks a lot for all your follow-up! 🙂

    Best,

    Franck

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Don’t worry about using the dev version for now. Final version will be available soon.

    Perfect! 😉

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Hi Franck,

    final version was released last week. Can you confirm it works and the topic can be closed?

    Peter

    Hi Peter,

    I have just verified on all my websites.
    Everything rocks. 🙂
    The topic can be closed.

    Thanks a lot for all the great work. 🙂

    Franck

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.