Support » Plugin: Replyable - Subscribe to Comments and Reply by Email » 2.2.9 causes fatal error

  • Updating to 2.2.9 crashed my site. After deleting the plugin and attempting to reinstall, I get this error:

    Plugin could not be activated because it triggered a fatal error.

    Warning: require(…/wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in …/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70

Viewing 15 replies - 1 through 15 (of 15 total)
  • Thread Starter Daniel J. Lewis

    (@djosephdesign)

    Since I can’t send a support ticket through the plugin, I sent one through the official website: https://replyable.com/support/

    Thread Starter Daniel J. Lewis

    (@djosephdesign)

    Sigh. But I forgot that 2.2.7 still has the “Unauthorised AJAX Calls via Freemius” vulnerability.

    I’m going to disable the plugin and pause my subscription until they fix the plugin. Maybe that will finally catch their attention.

    Daniel. Have you heard anything more? Not sure why but my replies to this thread have disappeared. I’m ok with version 2.2.7. Does your site crash when you have 2.2.8 activated?

    Still can’t update, even with version 2.2.9. it crashed. Here is the error message, i replaced my site root folder name below.

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 73 of the file /home/mysitename/public_html/wp-content/plugins/postmatic/vendor/composer/autoload_real.php.
    Error message: require(): Failed opening required ‘/home/mysitename/public_html/wp-content/plugins/postmatic/vendor/composer/../scribu/scb-framework/load.php’ (include_path=’/home/mysitename/public_html/wp-content/plugins/postmatic/vendor/phing/phing/classes:/home/mysitename/public_html/wp-content/plugins/postmatic/vendor/phpunit/php-file-iterator:/home/mysitename/public_html/wp-content/plugins/postmatic/vendor/phpunit/phpunit:/home/mysitename/public_html/wp-content/plugins/postmatic/vendor/symfony/yaml:.:/opt/cpanel/ea-php74/root/usr/share/pear’)

    • This reply was modified 9 months, 3 weeks ago by mswas.
    • This reply was modified 9 months, 3 weeks ago by mswas.
    Thread Starter Daniel J. Lewis

    (@djosephdesign)

    @baritoneuk That’s really weird! I don’t see your other replies anymore, either.

    2.2.7 _funcitons_, but has a security vulnerability. So iThemes Security kept warning me about it until I deleted (not merely deactivated) the plugin.

    2.2.8 crashes on activation, so it won’t activate.

    And 2.2.9 crashes my entire site.

    I’m just going to wait for 2.2.10.

    Same problem. Had to go in and x out the Postmatic folder to revive my site.

    Add me to the list of people who can’t update past 2.2.6. I’d like this resolved before my renewal comes due next month!

    @orgassist unfortunately support is not getting back to any of us, it seems. It’s a real shame, since this is an amazing plugin.

    I’ve installed version 2.2.3 (I think) and it works perfectly and I’ve carried on paying for the subscription. But I’m very nervous about it moving forward.

    mcreiz

    (@mcreiz)

    Is there any solution for the problem? I can’t install it, I wanted to try it together with WP Disquz.

    Warning: require(/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /postmatic/vendor/composer/autoload_real.php on line 70
    
    Fatal error: require(): Failed opening required '/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='/postmatic/vendor/phing/phing/classes:.:/opt/alt/php74/usr/share/pear') in /postmatic/vendor/composer/autoload_real.php on line 70
    Thread Starter Daniel J. Lewis

    (@djosephdesign)

    No good solution. You could downgrade to an older version of the plugin, but that leaves your site open to attack through a known vulnerability.

    I’ve contacted the company through Twitter and they’ve responded, but the developer himself hasn’t responded or done anything.

    So I had to cancel my subscription and delete the plugin until they fix the problem.

    orgassist

    (@orgassist)

    I have also downgraded for now and cancelled my subscription.

    What happens when you cancel your subscription? I was charged for a whole year recently. I wasn’t very happy about that. But I don’t want to lose access to the ability to receive comments via email and be able to reply to them. I don’t know how I’d cope without the service. But I also don’t really want to be paying for a plugin that isn’t working correctly and where they’re not responding to support questions

    Thread Starter Daniel J. Lewis

    (@djosephdesign)

    When you cancel, you lose access to the premium features you’ve been enjoying.

    But I can’t use them anyone since the plugin is broken.

    Hi, are there any alternatives at all to this plugin? I would desperately like to reply to comments via email. I tried to install 2.3 and it couldn’t connect to my server. Any help anyone can provide would be great.

    I had recently found the “Subscribe to Category” plugin, and Wordfence pointed out a vulnerability, so was looking for an alternative. I found Replyable, just tried to install, and got this fatal=error message:

    Warning: require(/homepages/18/d221467449/htdocs/clickandbuilds/LackawannaCoalition/wp-content/plugins/postmatic/vendor/composer/../myclabs/deep-copy/src/DeepCopy/deep_copy.php): failed to open stream: No such file or directory in /homepages/18/d221467449/htdocs/clickandbuilds/LackawannaCoalition/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70
    
    Fatal error: require(): Failed opening required '/homepages/18/d221467449/htdocs/clickandbuilds/LackawannaCoalition/wp-content/plugins/postmatic/vendor/composer/../myclabs/deep-copy/src/DeepCopy/deep_copy.php' (include_path='/homepages/18/d221467449/htdocs/clickandbuilds/LackawannaCoalition/wp-content/plugins/postmatic/vendor/phing/phing/classes:.:/usr/lib/php7.4') in /homepages/18/d221467449/htdocs/clickandbuilds/LackawannaCoalition/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70

    I am a real amateur, so I am just going to remove the plug-in and keep looking, I am posting this here in case it helps someone else. My host is IONOS, if it matters.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.