• Resolved Daniel J. Lewis

    (@djosephdesign)


    I just updated to version 2.2.8 and it crashed my site. Here are the logs.

    [23-Nov-2020 03:30:55 UTC] PHP Warning:  require(/REDACTED/wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /REDACTED/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70
    [23-Nov-2020 03:30:55 UTC] PHP Fatal error:  require(): Failed opening required '/REDACTED/wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='/REDACTED/wp-content/plugins/postmatic/vendor/phing/phing/classes:/REDACTED/wp-content/plugins/postmatic/vendor/phpunit/php-file-iterator:/REDACTED/wp-content/plugins/postmatic/vendor/phpunit/phpunit:/REDACTED/wp-content/plugins/postmatic/vendor/symfony/yaml:.:/usr/share/php') in /REDACTED/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70
    [23-Nov-2020 03:30:55 UTC] PHP Warning:  require(/REDACTED/wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /REDACTED/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70
    [23-Nov-2020 03:30:55 UTC] PHP Fatal error:  require(): Failed opening required '/REDACTED/wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='/REDACTED/wp-content/plugins/postmatic/vendor/phing/phing/classes:/REDACTED/wp-content/plugins/postmatic/vendor/phpunit/php-file-iterator:/REDACTED/wp-content/plugins/postmatic/vendor/phpunit/phpunit:/REDACTED/wp-content/plugins/postmatic/vendor/symfony/yaml:.:/usr/share/php') in /REDACTED/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70
Viewing 15 replies - 1 through 15 (of 18 total)
  • I had two websites go down when Replyable updated tonight. Both sites came back up when I deactivated the plugin.

    Same here – website crashed after updating the plugin.
    Used my latest backup for now.

    Thanks in advance for having a look into this.

    same here…

    Fatal erro:
    wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php’ (include_path=’/REDACTED/domains/buddho.nl/public_html/wp-content/plugins/postmatic/vendor/phing/phing/classes:/REDACTED/domains/buddho.nl/public_html/wp-content/plugins/postmatic/vendor/phpunit/php-file-iterator:/REDACTED/domains/buddho.nl/public_html/wp-content/plugins/postmatic/vendor/phpunit/phpunit:/REDACTED/domains/buddho.nl/public_html/wp-content/plugins/postmatic/vendor/symfony/yaml:.:/opt/alt/php74/usr/share/pear’) in /REDACTED/domains/buddho.nl/public_html/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70

    Same here

    Same issue.

    Warning: require(/home/s286/html/wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /home/s286/html/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70
    
    Warning: require(/home/s286/html/wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /home/s286/html/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70
    
    Fatal error: require(): Failed opening required '/home/s286/html/wp-content/plugins/postmatic/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='/home/s286/html/wp-content/plugins/postmatic/vendor/phing/phing/classes:/home/s286/html/wp-content/plugins/postmatic/vendor/phpunit/php-file-iterator:/home/s286/html/wp-content/plugins/postmatic/vendor/phpunit/phpunit:/home/s286/html/wp-content/plugins/postmatic/vendor/symfony/yaml:.:/usr/share/php') in /home/s286/html/wp-content/plugins/postmatic/vendor/composer/autoload_real.php on line 70
    Plugin Author Postmatic

    (@vernal)

    Hey Folks,

    Confirmed: there is a bug in 2.2.8 which affects some sites. We haven’t discerned where the conflict is but will be pushing a fix hopefully today. In the meantime, please roll down to 2.2.7, which can be found here (look under Previous Versions)
    https://wordpress.org/plugins/postmatic/advanced/

    More soon,
    Jason

    Plugin Author Postmatic

    (@vernal)

    Hey Again,

    We have rolled out a hotfix to address the crash issue. Please find the update in your WordPress dashboard.

    Thanks to everyone for the great error notices and for helping out.

    Jason

    Not seeing the update in the dashboard. 2.2.8 is installed, but not activated (fatal error).

    Here same problem, it is not possible to update when a plugin is de-activated because of error. Can we get the manual fix to alter the error by hand?

    OK I looked into the file autoload_real.php and line 70 was simply missing the end bracket }.

    I added this and now it errors again on line 74. it says: Parse error: syntax error, unexpected ‘}’, expecting end of file

    No sorry, this was not it. What can it be since Postmatic doesnt answer for a week now?

    Ok, I uninstalled the failing version and reinstalled the newest one. It works and keeps my old settings. For me this is resolved now.

    So sorry to tell you that it crashed my site again. Needed to rename the plugin to get the site up again.

    Plugin Author Postmatic

    (@vernal)

    Hey @vinz98, I’m glad you resolved the issue on your site. It may have been another plugin or system which was keeping your site from grabbing the correct update. I’m glad it’s resolved for you.

    Be well,
    Jason

    Yeah, thanks a bunch but I uninstalled it. My site is up for a while I hope.

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.