• Resolved mattschofield

    (@mattschofield)


    Hi

    Unfortunately the styling of our tabs has corrupted after updating to 2.1.1 on our staging environment.

    Developer Console throws the three errors below (I’ve modified our domain name in the entries below):

    Refused to apply style from ‘https://*ourdomain*/wp-content/uploads/3f19981ae0bd43f46afb51324c03b96f.css?generated=1637626647&ver=1.16.2’ because its MIME type (‘text/html’) is not a supported stylesheet MIME type, and strict MIME checking is enabled

    GET https://*ourdomain*/wp-content/uploads/98e534129ac3229d63c9ab945474d55d.js?defer&generated=1637626647&ver=1.16.2 net::ERR_ABORTED 404

    GET https://*ourdomain*/wp-content/uploads/98e534129ac3229d63c9ab945474d55d.js?defer&generated=1637626647&ver=1.16.2 net::ERR_ABORTED 404

    Is anyone else seeing this problem?

    Edit. Specs below:

    WP Version : 5.8.2
    WPMU: No
    MySQL Version : 5.7.35
    WP Table Prefix : {amended}
    PHP Version : 8.0.12
    Session Save Path : /opt/alt/php80/var/lib/php/session
    WP URL: {amended}
    Server Name : {amended}
    Cookie Domain : {amended}
    CURL Library Present : Yes
    Debug File Write Permissions : Writable`

    PHP Info

    PHP Version : 8.0.12
    PHP Memory Usage: 23.88 MB
    PHP Memory Limit : 256M
    PHP Max Upload Size : 32M
    PHP Max Post Size : 32M
    PHP Allow URL fopen : On
    PHP Display Errors : Off
    PHP Max Script Execution Time : 30 Seconds

    Active Plugins

    All In One WP Security	4.4.9	https://www.tipsandtricks-hq.com/wordpress-security-and-firewall-plugin
    Starter Templates	2.7.5	https://wpastra.com/
    Better Search Replace	1.3.4	https://bettersearchreplace.com
    CoBlocks	2.19.1	
    Code Snippets	2.14.2	https://github.com/sheabunge/code-snippets
    GDPR Cookie Consent	2.0.6	https://www.webtoffee.com/product/gdpr-cookie-consent/
    Custom Layouts - Post + Product grids made easy	1.4.5	https://customlayouts.com
    Download Manager	3.2.24	https://www.wpdownloadmanager.com/purchases/
    Duplicator	1.4.3	https://snapcreek.com/duplicator/duplicator-free/
    Imagify	1.10	https://wordpress.org/plugins/imagify/
    Insert Headers and Footers	1.6.0	http://www.wpbeginner.com/
    Mail Integration for Office 365/Outlook	1.8.2	
    myStickymenu	2.5.6	https://premio.io/
    Pages with category and tag	0.9.0	https://dev.back2nature.jp/en/pages-with-category-and-tag/
    Password Protected	2.5	https://wordpress.org/plugins/password-protected/
    Popup Maker	1.16.3	https://wppopupmaker.com/?utm_campaign=plugin-info&utm_source=plugin-header&utm_medium=plugin-uri
    Post Duplicator	2.23	
    Redirection	5.1.3	https://redirection.me/
    Relevanssi	4.14.4	https://www.relevanssi.com/
    Search & Filter Pro	2.5.11	https://searchandfilter.com
    Category Order and Taxonomy Terms Order	1.5.7.7	http://www.nsp-code.com
    Yoast SEO	17.6	https://yoa.st/1uj
    Asset CleanUp: Page Speed Booster	1.3.8.4	https://wordpress.org/plugins/wp-asset-clean-up/
    WP Tabs	2.1.0	https://shapedplugin.com/plugin/wp-tabs-pro/?ref=1
    WP Rocket	3.10.4	https://wp-rocket.me
    WPForms Lite	1.7.1.2	https://wpforms.com
    • This topic was modified 8 months, 2 weeks ago by mattschofield. Reason: Forgot to include environment
Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter mattschofield

    (@mattschofield)

    I have found a part of the problem, but not yet found why the update 2.1.1 causes it.

    The three errors I listed in the original post are actually being reported for a css and JS file for the plugin “Popup Maker”, version 1.16.3.

    Upon updating WP Tabs to 2.1.1, the CSS and JS files stored in /wp-content/uploads for Popup Maker are deleted. By deactivating and reactivating the Popup Maker plugin, it’s CSS and JS files are written and the error is resolved.

    I’m not sure what part of update 2.1.1 is causing this behaviour but please look into it.

    Also, regarding the styling/CSS changes as part of the 2.1.1 update. Indenting of bullets (lists) appears to have been lost when outputting the description to the front-end. As has spacing that should occur between Paragraphs and Headings written within the description (if a single description contains multiple headings and paragraphs).

    Plugin Support Bayejid Ahmed

    (@bayejid00)

    Hi @mattschofield,

    Thank you for reaching us.

    I would like to review the issue to figure it out.

    Could you provide the page link to review the issue and resolve it?

    Thread Starter mattschofield

    (@mattschofield)

    Thanks, @bayejid00

    Unfortunately the stage needs to remain behind http authentication. Do you have an address I could share a temporary password?

    Plugin Support Bayejid Ahmed

    (@bayejid00)

    Hi @mattschofield,

    Please open a support ticket here claiming your issues to get a rapid response. Our support team will help you in a better way.

    Thank you.

    Thread Starter mattschofield

    (@mattschofield)

    Thanks @bayejid00

    Support ticket submitted

    Thread Starter mattschofield

    (@mattschofield)

    @bayejid00 I’ve found a problem since submitting my ticket that you may be able to reproduce. The WP Tabs 2.1.1 update has also impacted the styling of a plugin in the back-end.

    The plugin is Search and Filter by Code Amp. To reproduce:

    1/ Deactivate WP Tabs plugin
    2/ Install and Activate Search and Filter by Code Amp
    3/ IN WordPress Dashboard, Navigate to Search and Filter > Search and Filter.
    4/ Select “Add a new search form”
    5/ Observe the styling of the “Setting and Defaults panel”, with the buttons for “General… Display Results… Posts…” along the top.
    6/ Activate WP Tabs plugin
    7/ Repeat steps 3, 4 and 5 above. Observe the styling change to the “Settings and Defaults” panel since activating the WP Tabs plugin. The options for “General, Display Results…Posts…” etc… are now barely visible.

    I hope that’s helpful and you might be able to reproduce the problem.

    Plugin Support Bayejid Ahmed

    (@bayejid00)

    Hi @mattschofield,

    We have replied to your support ticket and resolved the issue you faced.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘2.1.1 update errors’ is closed to new replies.