Support » Plugin: Radio Buttons for Taxonomies » 2.0 has duplicate meta boxes, 1.8.3 does not

  • Resolved carasmo

    (@carasmo)


    I upgraded to 2.0 from 1.8.3 and there’s duplicate metaboxes of any taxonomies using this plugin, when I downgrade it goes back. When 2.0 is installed one set of metaboxes doesn’t work. I’m in the latest WordPress install.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author helgatheviking

    (@helgatheviking)

    Is this a custom post type? Does this issue exist with all other plugins disabled? There is a version 2.0.1 that it appears I forgot to push to the .org. I’ll try to do that later. I’m not sure that will resolve your issue though since it was primarily a fix for older versions of WP.

    Thanks! It’s not a CPT, this is the blog post type. It doesn’t happen with CPTS, that is weird.

    I installed 2.0.1 and it’s still there.

    I disabled the plugin “Disable Gutenberg” (https://wordpress.org/plugins/disable-gutenberg/) and the duplicate second set of taxonomies (tags and cats) bug is gone, when Disable Gutenberg is active, the duplicate taxonomies in blog post types appears again. I disabled plugins and theme and set to 2019, still there.

    I renabled Disable Gutenburg and looked in the Screen Options:
    When 2.0.1 is installed this is what I get in the screen options. Double checkboxes with different, but similar names. One set doesn’t work.
    https://christinacreativedesign.com/crap/rbft-2.0-screen-options.png

    When 1.8.3 is installed this is the screen options choices, the duplicate checkboxes are not there.
    https://christinacreativedesign.com/crap/rbft-1.8.3-screen-options.png

    I replied but the links of screen shots forced it to be moderated. I’ll check back.

    Plugin Author helgatheviking

    (@helgatheviking)

    Hi, I see your screenshots thank you. My plugin tries to add and remove a metabox if the use_block_editor_for_post_type() is returning true. This value can be filtered, and the Disable Gutenberg might want to consider doing that so that other plugins (like mine) can detect when Gutenberg has been disabled in some non-default way. Currently, I don’t believe there’s anything I can do on my end.

    You could try adding the following as a snippet in your theme’s functions.php:

    add_filter( 'use_block_editor_for_post_type', '__return_false' );

    In my opinion that should be added to the Disable Gutenberg plugin and I will open a support thread for them. I’m sure it would help if you’d confirm that snippet works like I hope.

    It works! Thank you so much.

    Their plugin “supposedly” allows you to select which post types and roles you want to use Gutenberg with, it has never worked since I last tested when playing around. The thing only works if you just disable Gutenberg entirely.

    I was just about to send a support request, I see you got there already.

    Plugin Author helgatheviking

    (@helgatheviking)

    Glad to hear it. There’s a second parameter in the use_block_editor_for_post_type that is $post_type. That may help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.