Support » Plugin: Magic Liquidizer Responsive Table » [2.0.2] Cause error

  • Resolved RGhost

    (@rghost)


    Hello!

    2.0.2 Cause error and break the site (2.0.1 works well)

    Fatal error: Can’t use function return value in write context in /var/——/wp-content/plugins/magic-liquidizer-responsive-table/magic-liquidizer-responsive-table.php on line 263

    Please fix it!

Viewing 14 replies - 1 through 14 (of 14 total)
  • We are seeing the same issue. Had to delete the plugin from disk to get the site to work even in admin dashboard.

    Yes, same fatal error. Plugin deleted.

    Plugin Author Elvin D

    (@esstat17)

    Hi Guys!

    I apologize for the error that this plugin causing you. Upon checking on the code line, this !empty(function) is causing an error to lower PHP versions.

    I assigned it first to $variable then do the !empty($variable).
    Please let me know if errors still occur.

    I need your help so other users could benefit from it.

    Thank you!

    Reinstalled. Appears to be working Elvin.

    Thanks!

    Plugin Author Elvin D

    (@esstat17)

    Welcome and thanks for your help!

    Thank you for fixed it!

    My web site is down after the recent update and is showing an error in line 263.
    However I don’t understand the correction that needs to be done?
    I have the file open in an editor but don’t understand your correction answer?
    Maybe you could cut and paste the corrected line 263?
    Thanks!

    Plugin Author Elvin D

    (@esstat17)

    Hi @prairietech! I thought this issue has been resolved already. However I appreciate you raise to open this concern. What version are you using? I would gladly want to connect you via innovedesigns.com contact form for this is urgent matter.

    Sorry for inconvenience.

    Version 2.0.2
    I’m a pretty much a green wordpress user. I can fumble my way around cutting and pasting code. But writing and understanding code is something I am unable to grasp.

    You listed the solution above but it is over my head.

    If you could show me the correct code for line 263, that should get my web page back up.

    Oh, did you mean php version?? 5.6.30

    Plugin Author Elvin D

    (@esstat17)

    plugin version 2.0.3 is the latest one.
    Also lower php versions recently reported errors on that the same line of code for 2.0.2 version.
    Can you update it to the latest version 2.0.3?

    I’ll see if I can figure out how to update to 2.0.3
    But since I can’t log into my WordPress wp-admin, (I get a this page not working error) I’ll try loading the new version via my web host’s cpanel instead.
    Now if I can figure out where to download the new version……..it doesn’t look like Github is very current.

    prairie, if you are unable to update due to the error and it’s easier for you, you can delete the plugin from your wp-content/plugins folder. Your site will work again and you can reinstall normally through admin dashboard.

    • This reply was modified 1 year, 1 month ago by  betterbrain.

    Wow! Why didn’t I think of something as simple as that!!
    Done, problem solved!!
    Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[2.0.2] Cause error’ is closed to new replies.