WordPress.org

Forums

[resolved] 1mb limit for media. What am I missing to fix this? (13 posts)

  1. njdespres
    Member
    Posted 2 years ago #

    My site is http://www.gtcchorus.org and I am trying to do it as a favor to this non-profit. I have it configured to direct to my main website which has a limit of 64mb I believe. I need to be able to upload an mp3 recording of the chorus to play on the homepage and 1mb is way too small!
    Thanks for any help anyone can offer. I really appreciate. I am not a web developer but can do what you tell me with decent instruction. Browsed through the forums for hours and can't find the fix for me.
    http://www.njdespres.com/phpinfo.php

  2. GuyM1952
    Member
    Posted 2 years ago #

    I could be wrong, but unless you're using a WordPress Multi Site set up (which I feel certain is not the case) I don't believe there is any sort of file size upload limit set via WordPress. With multi-site setups, as I recall, there is an option to set such a limit.

    Again - I may be wrong - but that sounds like a limitation set in your php.ini file. If that's the case, you would need to find post_max_size and upload_max_filesize and set them to some reasonable limit. All of this presumes you're hosting this yourself. If you're not, you need to contact your web host to see what's going on.... If you can't upload an MP3, it's set to something very low.

    Finally - maybe I'm wrong. But I have about 45 WordPress sites and I do not recall ever seeing such a setting, nor, having to adjust anything of this kind. Again, it's based upon the web server's PHP configuration.

  3. njdespres
    Member
    Posted 2 years ago #

    Everything in my PHP settings, which I posted above, is supposedly right. I contacted my hosting provider and they said it is within WordPress and can't figure out how to fix it either. When I go in to media, library, add filed, it is 1mb which is soo small I can't add an audio file at all.

  4. GuyM1952
    Member
    Posted 2 years ago #

    Man - that's weird..... I know of no settings in WordPress where you set that sort of limit - except in a Multi Site setup. Is this a WordPress Multi Site set up....? And I install WordPress almost every day - dead serious. I actually have about 40 live sites and I'm always testiing things, deleting things, etc.

    What version of WordPress are you using?

  5. I have it configured to direct to my main website which has a limit of 64mb I believe.

    What do you mean here?

    If I click your first link.. it takes me to 'gtcchorus.org'.

    If I click your second link.. it takes me to 'njdespres.com'.

    Are both of these hosted on the same server? Are you sure you're targeting the correct php.ini file?

  6. njdespres
    Member
    Posted 2 years ago #

    Yes. They are hosted on the same server.

  7. njdespres
    Member
    Posted 2 years ago #

    Yes. I had my hosting support check it out and they can't figure out what is wrong and suggested I contact WP to find a solution.

  8. GuyM1952
    Member
    Posted 2 years ago #

    I failed to see your PHP info page link.... Stupid question: how big is your MP3...? Is it larger than 64 megabye?

  9. njdespres
    Member
    Posted 2 years ago #

    I fixed it. It was in WordPress, network settings. Duh! Thanks.

  10. GuyM1952
    Member
    Posted 2 years ago #

    AHH! I told you - in a WMU setup there is a setting for that...

  11. njdespres
    Member
    Posted 2 years ago #

    There you go! I could have saved a million hours today!

  12. GuyM1952
    Member
    Posted 2 years ago #

    You'll have to get up early in the morning to make as many knuckleheaded errors as me..... Glad you got it fixed.

  13. You'll have to get up early in the morning to make as many knuckleheaded errors as me.....

    Amen... brother!!

    @njdespres,

    Very glad you got it fixed!

Topic Closed

This topic has been closed to new replies.

About this Topic