Support » Plugin: Yoast SEO » 19.5.1 – Yoast Fatal Error on website

  • Resolved mvfsmart

    (@mvfsmart)


    Today I’v made a upgrade from 19.1 to 19.5.1

    When I make a search for something on the website I get a critical error. 500.

    I saw that there was a bug making critical errors. Maybe this is not resolved yet. I’v returned to the 19.1 version and like this I have no bugs on the website.

    Here is the log.

    Fatal error: Uncaught Error: Cannot use object of type WP_Query as array in \wp-content\plugins\wordpress-seo\src\context\meta-tags-context.php:625 Stack trace: 
    
    #0 \wp-content\plugins\wordpress-seo\src\presentations\abstract-presentation.php(64): Yoast\WP\SEO\Context\Meta_Tags_Context->generate_main_image_id() 
    
    #1 \wp-content\plugins\wordpress-seo\src\context\meta-tags-context.php(592): Yoast\WP\SEO\Presentations\Abstract_Presentation->__get('main_image_id') 
    
    #2 \wp-content\plugins\wordpress-seo\src\presentations\abstract-presentation.php(64): Yoast\WP\SEO\Context\Meta_Tags_Context->generate_main_image_url() 
    
    #3 \wp-content\plugins\wordpress-seo\src\context\meta-tags-context.php(639): Yoast\WP\SEO\Presentations\Abstract_Presentation->__get('main_image_url')
    
     #4 \wp-content\plugins\wordpress-seo\src\presentations\abstract-presentation.php(64): in \wp-content\plugins\wordpress-seo\src\context\meta-tags-context.php on line 625
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hey @mvfsmart,

    Thank you for using Yoast SEO and for reaching out!

    Sorry to hear you had issues searching on your site. The error we had with 19.5 was in relation to Yoast SEO Premium, so if you are/were not running this on your site, it was not related to what you were experiencing.

    To be able to investigate more, we’d need more information. Is your WordPress installation at the latest version as well as all other plugins and themes on your site? Were you searching on the front end of your site, or in your Dashboard? Can you share a URL to your site?

    Thread Starter mvfsmart

    (@mvfsmart)

    Hello,

    I have all my plugins and wordpress at latest version. If I disable the Yoast plugin or having the version I’v said, I have no problems. I was using the default search box in the front-end.

    I don’t feel confortable to share the website here in public, because its still in staging mode, almost good to go live. Is there any option to share only with you?

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hey @mvfsmart,

    Sorry for the late response.

    No, there is no way here to share information privately on the forums. (unless you use the extra field URL when you open a topic, but that is still public for all who is logged in here on wordpress.org.

    If you need more personal support over email, please know that is included in a Yoast SEO Premium subscription. If you’re interested, more info can be found here: https://yoast.com/wordpress/plugins/seo/

    Thread Starter mvfsmart

    (@mvfsmart)

    Hello,

    I believe Iv discovered the bug.

    It seems it was the theme’s fault. Iv just changed the get_header() function, called in the index.php to a upper position (I have search functions on top and having the get_header() in the first place seems to fix the issue.

    btw, this was on the Rela theme.

    But now I have other bug maybe. The yoast are not showing inside elementor. Any clue? In the normal pages i see the yoast options. But inside elementor i dont. Maybe a bug for another thread?

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hey @mvfsmart,

    Thank you for following up. Yes, creating a new topic for a new concern is the best way forward, sorry for our late response here.

    In any case, please check if the issue also occurs with our latest release from today (19.7) and if so, feel free to create a new topic. I’ll mark this topic as resolved as the theme issue is resolved. Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.