Support » Fixing WordPress » 1.5.1 RSS issue

  • I did a handful of updates today, 8 of them appear to be fine.

    the 9th (of course, mine) has an issue:

    only wp-feed.php is returning with a feed.

    domain/feed/ (which usually works) is a blank page
    as are the other feed pages (even when called directly)

    I’ve tried:
    replacing htaccess with a fresh file (re did the permalinks)
    deleting the files and re installing them (ran upgrade.php again too, and it let me)
    deleting the files again and re installing them
    only deleting the rss related files and re uploading them.

    Is anyone else having this issue?

    I’m surprise that the other 8 are operating just fine, but this one is clunky.

    help?

Viewing 15 replies - 16 through 30 (of 37 total)
  • You have to create and publish a new post and it will work again. It worked for me. I tried just created a test post but that didn’t work. So I spent the time to make a new post and published it. RSS works fine now.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    There are a few fixes and some good info here: http://mosquito.wordpress.org/view.php?id=1323

    Any fix info for those of us who don’t have an SVN client installed? Like the code that has changed in order to repair the RSS feeds? 😀

    I just posted new entries in the offending blog (mine) and the /feed was fixed.

    nothing special, but it is a weird problem.

    I have last trunk versio, update seconds ago, wp-atom.php send html tags () in the summary. It should be plain text.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    gallir, please report the bug to the proper location. That bug is also a separate issue from the one discussed above. If you would like to discuss it here, please start a new thread.

    http://codex.wordpress.org/Submitting_Bugs

    allrighty, now my main RSS feed works with (another) new post, but the category feeds are still screwed.

    My feeds were broken because of a plugin, not because of the upgrade. Since I was in the middle of transferring my site to a new server at the same time as the 1.5.1 upgrade, and moving my WordPress install to a subdirectory, my feed won’t be subject to the same problems as a typical install. So don’t make comparisons to what I’ve done. Besides that, it’s working fine now. 🙂

    Right, It’s true.

    I just did a clearing out of my cache and the /feed doesn’t really work.

    Seems like it’s getting killed after a period of time?

    A new post will revive the feed output, but it’s not stable, and dies (in 24 hours?)

    This is definitely a bug and needs to be corrected.

    F.

    @vinyl_warrior: I press SHIFT and F5 (or mouse on the reload button of my Firefox) to really get the page reloaded.

    @dss: Exactly this effect I recognize now, this morning. There is no feed anymore, but there has been one yesterday evening.

    This actually has been fixed by anonymousbugger

    I wrote it up for simplicity’s sake here

    Not my work, but the fix has corrected my feeds and “/feed” page’s output.

    Thank You Anonymousbugger!!!

    dss, thanks for posting anonymousbugger’s solution, it worked for me. One thing you might do to make the change more obvious is point out that only one line actually needs to be changed, possibly by highlighting that line in a different background color.

    good idea.

    makes it even simpler!

    i like that!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Dougal has posted a new solution, and it appears to be better, though time will tell.

    http://mosquito.wordpress.org/view.php?id=1323

    I’m going to restore my files to the default installation files from the 1.5.1 zip on one of my installations and use Dougal’s diff as the fix and see if there’s any difference.

    more in a day or so.

Viewing 15 replies - 16 through 30 (of 37 total)
  • The topic ‘1.5.1 RSS issue’ is closed to new replies.